ExtrudeCrv makes a hole when extruded

When I extrude a closed curve with the command “ExtrudeCrv”,
it was automatically capped, but suddenly it is no longer capped.
Do you know why this is?

The reason I ask this question is because I would like to extrude the curve data as shown in the image, but it would be very time consuming to cap it later.

Hello - whether to make a solid or not is controlled at the command line and by whether the input curve is closed and planar - if you launch the command from the Solid menu it will try to cap, if you launch it from the Surface menu it will not; same with the surface and solids toolbars - these just set the Slid=Yes/No command line option.
Does that make sense with what you are seeing?


1 Like

I Understood.
I did not know that such a choice could be made on the command line.
Thanks for the advice!