Extrude Curve Straight, I can't figure out how to Cap


#1

Hello, I just started using Rhino for mac. I have never done 3d I started on AutoCAD and have been watching you tube vids of people using Rhino on Windows to expedite my learning process. When I select Extrude Curve Straight I can’t figure out how to cap. The videos I watch have a dialog box that you can enter yes or no to cap a surface. The only dialog box I found so far is the history which shows no for capping. Could someone point me in the right direction?


#2

Try selecting Extrude curve straight from the Solid menu. Your input curves must be planar and closed for it to make a solid.

HTH, --Mitch


#3

Thanks Mitch! I’m using a joined polyline. How do I make sure it is closed? Kevin


(Pascal Golay) #4

Hi Zamm - use the What command to get info about the curve; SelOpenCrv should not select it, selClosedCrv should and if it is open, CrvEnd and CrvStart will mark the ends.

-Pascal


#5

Sorry for the delay, I’m learning this in my spare time while running my business. Here is the info on the curve:

curve
ID: 06d5d273-5535-4bfa-b8b8-f2bb85afc372 (75)
Layer name: Body Outline
Render Material:
source = from layer
index = -1
Geometry:
Valid curve.
Closed NURBS curve
start = (16.8118,6.6798,0.0000)
end = (16.8118,6.6798,0.0000)
degree = 3
control points: non-rational, count=124 (1 duplicate)
knots: non-uniform, domain = 0.0000 to 41.0000
clamped at start and end
Curve is not smooth. If you explode it, it will become two or more curves.

I’m trying to make a solid with fillet edges on the top and back


(Pascal Golay) #6

Hi Kevin - try this - make a rectangle, select it, and from the Solid menu choose Extrude planar curve > Straight Then, make a second rectangle, select it and from the Surface menu, choose Extrude curve > Straight. If you only pull out the extrusion and click, the first one should be a closed box and the second one open top and bottom. If, before you set the extrsuion length and finish, you look at the command area, you’'ll see that Solid=Yes in the first case and No in the second. You can change this on the fly while the command is running but the menu items explicitly set the option differently.

-Pascal


#7

Thanks Pascal,

I will try that now. My biggest problem is I can’t find the dialog box. I know that would fix a lot of my current issues.

-Kevin


#8

There is no dialog box for Extrude. It’s all on the command line/command prompt and/or in the menus. --Mitch


#9

I don’t have the command dialog box on top that I see in just about every tutorial.


#10

That’s most likely because you’re looking at Windows Rhino tutorials. Mac Rhino does not have a command line per se like the Windows version. The command prompt in Mac Rhino is in the upper left corner of your image where you see the word “Command”.

Your command options will also appear below that when the command is in progress.

HTH, --Mitch


#11

Thank you, I thought I was going crazy since most tutorials are on the windows version.