Extrude command; surfaces dissapear

Hello all!
I’m having problems with my rhino 5:

Using the “extrude curve/surface” commands, object surfaces tend to “dissapear” leaving a white “ghostlike” wireframe, that cannot be selected/deleted or purged.


I get the same issue with larger models (appr. 100 mb), or when I apply a material to an object.

The program has been running fine until around 1st January where I started getting these issues.

I have a NVDIA QUATRO T2000 graphics card installed. I have tried reinstalling my graphics card driver and my rhino app, to no avail.

Does anyone have experience with this type of issue and can point me towards how i solve my isssue?

Cheers/ Chris.

Hi Chris - so some of your objects looks correct and some show outliney, is that correct? Can you please post a file with one or more of the input curves and the resulting extrusion? Are the objects very far from the world origin?


Hi Pascal.

I made a new simple model to show my error. The shapes are modelled around 0,0,0.

I created 3 simple shapes; 2 of them with the error:

  • The planar surface i get no errors.
  • The extrude crv i get no “immediate” error, but the edges are white for some reason (?)
  • THe extrude crv and assign material, the object “dissapears”, but the white edges stay. These edges cannot be selected or purged.

I have enscape installed as a plugin and “rhinogrow” also. I have not tried to reinstall these (?)

TEST 1.3dm (63.6 KB)

Hi Chris - a test would be to block/disable these plug-ins in Options > Plug-ins page and then close and restart Rhino.

I’ll take a look at your file. So far it all behaves as expected…


i disabled plugins (along with grasshopper) and restarted.
I still get the same error, unfortunately.

Hi Chris - I guess I need a blow-by-blow. Starting with the file you posted - what are the exact steps? For 5-year olds - what material do you change to, what display mode, (preferably a default one), is Solid=Yes or No when you extrude, etc.


Hi P
Here goes:
(displaymode shaded)

  • (cmd) rectangle
  • (cmd) extrudcrv
  • I go to “properties” to change material to “by object” instead of “bylayer”, but as soon as I do, the surfaces dissapear, and im left with the “white edges”.

and thats it…?

Ah. This is a V5 file, I missed that, at the top … hold on.
Still behaves in V5, here.
Does this one do the same thing for you?
TEST 1_noUserData.3dm (35.8 KB)


Yes, the error is still there :frowning:

Actually, this is wierd. I just downloaded a trialversion of rhino7, and the error seems to be gone?

Right, I was testing 7 before, but I still do not see it in 5. Can you please show a screenshot of Options>PLug-ins page filtered for “Plug-ins that do not ship with Rhino”?


Ok, i see a couple more i should disable, i didnt know about that function.

aaaand now it works :smiley:

It seems i just had to hit the right plugin. Thankyou for your time!

I suspect the clippingbox plugin was the culprit…