Extreme slowness of VA in viewport

Hi to all,
the problem that I describe below has already been discussed in another post, but unfortunately I have not found solutions on this. The problem lies in the extremely slow VA in viewport.
I state that before writing the post I have already tried with the following options:

  • disable third-party plug-ins;
  • disable grasshopper;
  • try with different series of nVidia drivers;
  • try with earlier versions of VA than 2.11.3.

Each attempt described has not brought benefits, with VA the viewport is so slow as to stall Rhino (I’m talking about trivial operations such as the creation of walls or the insertion of windows or doors).

The following is the System Info

Rhino 7 SR10 2021-9-13 (Rhino 7, 7.10.21256.17001, Git hash:master @ 68677dc86520a0de9485d8b8fa2e841e757733f3)
License type: Commercial, build 2021-09-13
License details: Cloud Zoo

Windows 10.0.19043 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA RTX A4000 (NVidia) Memory: 16GB, Driver date: 9-13-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 472.12
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-13-2021
Driver Version: 30.0.14.7212
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 16376 MB

Thanks in advance for any other tips on this…if they exist at the moment.

B.

Hello @Beppe_Barone,

Please, could you send us your file to visualarq@asuni.com? I will take a look to it to see what might be causing such a slow performance.

Could you send me this other post, so that I can check all the information about this issue so far?

@alfmelbev Hi Alfonso,
the post that i referrerd is this > Visual arq slow performance.

I send a file in few min.

B.

@alfmelbev

File sent.

Thx

Hello @Beppe_Barone,

This post is previous to the release of VisualARQ 2.11. In that version speed was improved, so those problems should be solved.

I have been testing your file with VisualARQ 2.11.3 and it worked fine to me:

Performance

Does the slow performance happens if you disable VisualARQ as well? You will not be able to create walls, windows or doors, but maybe you can reproduce it with other Rhino commands.

Did this always happened or did it start after any change in Rhino?

@alfmelbev
Hi Alfonso,
i know that that post was referring to a previous version, but the video posted by the user of the post is identical to what happens to me with the current version of VA. The problem of slowness is not inherent in the speed of movement of the geometry once created, but precisely in the creation of the geometry. In other words when I try to create walls, insert windows, etc etc, VA is very very slow. Rhino has no slowdowns of any kind, only when I work with VA does the problem show up.
The really strange thing is that with the previous video card these problems did not exist. At this point I believe there is some sort of incompatibility with my current RTX A4000 and VA, as it is the only recent change to my system. On the secondary pc (where the old video card is installed) I have installed VA in demo and there are no problems. Personally I have done all the possible tests, but the problem still exists.

B.

Hi @Beppe_Barone,

We don’t have previous reports of problems with video cards. If the problem is not about the display, it shouldn’t be related with the video card. Are you using an AMD Ryzen processor? If not, which one are you using? Did you make any updates in your PC before the problem started to happen? (Windows, Rhino…)

@alfmelbev

It was one of the first things I did, which was to uninstall the latest win 10 updates.

My cpu is an i7-5820k.

Hi @Beppe_Barone,

Please, could you disable the hardware acceleration of the OpenGL? Let me know if that changes something.

To disable it, you just need to move this slider to the left and restart Rhino afterwards.

@alfmelbev
No improvement, identical behavior.

@alfmelbev
Hi Alfonso,
after trying everything (including reinstalling Rhino 7 and VA from scratch) I tried installing RH6 and VA for 6 as a last resort. Not surprisingly, VA for 6 is practically a bolt of lightning!
I trust that in the next updates the situation (obviously for me) will improve to be able to return to the “classic” combination.
Soon,

B.

Hello @Beppe_Barone,

Ok, thank you for the update. If it is working fine with Rhino 6, then it must be a problem involving Rhino 7 or VisualARQ for Rhino 7. We will keep this in our list in order to find a solution. If you find out any more relevant data about this issue, please, let us know.

@alfmelbev
Hi Alfonso,
if there are any developments in this regard, I will definitely keep you informed.

B.