Exporting surfaces to dwg for CAM

rhino
cam

#1

Hello all,

This is my first time posting and I’m new to Rhino. I’ve come across a problem that I’ve spent a lot of time on but can’t solve so hopefully someone here can help me!

I’m trying to machine a 3D model of a mountain on a CNC router, I’ve used Sketchup to create the model of the terrain and saved this as a .skp. This opens as a mesh in Rhino, I’m looking for a smoother flowing surface than all the triangles so I’ve used “ExtractPT” and “Patch” to make the surface I want. This model then has to be split into layers to make the pieces fit within the machines capabilities. I did this using “Contour” and “Split”, the screenshots below shows what I’m left with…


I then exported these layers individually as dwgs for my CAM software which is Genio, but then when I apply my surface finishing operation to the surface, the rest of the terrain suddenly re-appears! As in on the bottom layer the top should be a flat for the next layer and only the outer area is to be machined but the CAM software is calculating toolpaths for the entire mountain that’s not even shown in the part.

Genio will only accept a dwg or dxf but I have tried exporting in other formats then used Inventor and Vectorworks to try create new surfaces and to start from the beginning of splitting the full model into layers. I’ve also used AutoCAD to try get it working because Genio is based on AutoCAD. I keep getting the same result through each different route so I’m out of ideas…?


#2

Maybe this method works:
Turn it into a block before slicing it using Wirecut. Like this.


Use the following commands :

DupFaceBorder on your surface (not sliced yet) = Curve1
ProjecttoCplane on Curve1 (Copy=yes) = Curve2
Move Curve2 to the right position for the thickness of your block of material
Loft Curve1 with Curve2
Planarsrf on Curve2
Use Join on all the surfaces to create a closed polysurface.

In front view draw lines for slicing (spacing is the thickness of your material) your 3D-model and use these lines with “Wirecut” (KeepAll = Yes).


#3

I followed that method but have still got the exact same result…
This is what I see on screen when I open the dwg in my CAM software:

Then I apply the machining to the surface around the edges and the entire surface suddenly re-appears…

Does anyone know if this surface information could be lost by converting to a different file type and back to a dwg maybe? Or any other suggestions?


#4

Strange. Can it load Meshes? Perhaps if you turn the surfaces into meshes using the Mesh command it works?


#5

I originally tried to use the mesh model from Sketchup but the CAM software was just getting bogged down and crashing with the thousands of little faces, that’s one of the reasons why I created a new surface with patch


(Wim Dekeyser) #6

If you keep it in NURBS, then the underlying surface will continue to be there. You can shrink the surface to get rid of some of it but that won’t do anything for the largest bottom part. Your alternative is to save and export as mesh.

(or find a setting in the CAM software that respects trims in NURBS surfaces).

You could play around with the messing settings in Rhino to perhaps find one that doesn’t crash the CAM software.


#7

I’ve spent some time playing around with the meshes and haven’t had any success, I thought I had originally used a mesh but I actually converted it to a polysurface using “meshtonurbs”. Genio won’t work with meshes. One method I tried was to convert the surface of one layer to a mesh and then back to a polysurface, I brought this into the CAM but it crashed and didn’t show what toolpaths it was trying to calculate. Should this method work or will the original nurbs information still go with it? If not I might spend some more time trying to reduce the polygon count in the mesh and see if that will work.

Could anybody tell me if it’s possible to create a surface using points and boundary curves like what I’ve shown in this screenshot?


I got those points and curve from one of the layers which was split from the full model.


#8

Please can you post the model? This should be fairly straight forward… He says.

Also, what machine are you using and what file types do you normally use/find successful?

Andy


#9

I’m using a SCM Pratix Z2, Genio for the CAM software.
My normal workflow method is to draw my models in Inventor or Vectorworks and export those as dwg, Open the dwg in Genio, which is AutoCAD based so use the “explode” command to break the full model into lines, arcs, surfaces etc…
For 2D drawings I normally output them as a dxf with layers for each operation and then import into Genio which has an import wizard to automatically apply tooling to each layer.
For the 3D models I have to apply the machining operations as needed then output the code which will be in .pgm format. This is then opened in Xilog at the machine and can be run.

This screenshot shows what’s in the file,
Top left is the points extracted from the sketchup mesh
Top right is the ideal 2 layers I want!
And below them is parts I’m trying to work on at the minute

Diamond Hill Model.3dm (1.6 MB)

I greatly appreciate all the help so far!


#10

Here is a quick example of how to (and not to do) what I think it is you’re after.

I’ve just used my first hit without finenessing the screen cast so apologies for the bitty nature:

http://screencast-o-matic.com/watch/cbewl26Mle

I hope that helps

Andy

[What I forgot to say is… Although I’ve recreated the steps provided by the other guys, you can explode the model and use those surfaces without it being so heavy on faces etc, unless that’s the look you were after?]


#11

Thanks Andy for taking the time to make that screen casting,
but I don’t think that method will make any difference when it’s brought into the CAM software, it’s still creating the layers from the original surface unless I’m missing something? What does ShrinkTrimmedSrf do at the end of the video?

What I was trying to do, was create a surface using only the points and boundary curves shown in the second last screenshot I posted. My thinking behind this is that the exported dwg shouldn’t contain all the nurbs information that’s causing the issues.


#12

I tried that method and the whole surface has reappeared again when I’ve applied tooling :unamused:


#13

Genio is apparently using a license of AutoCAD to operate. The native solid format of AutoCAD is ACIS. Autocad should report the object is a solid if you created a watertight object.

Have you tried using a .SAT file instead of .DWG?

Not sure exactly how much this will help, but it might be useful to know if you are getting surfaces that are stitching together on the receiving end.


#14

Hmmm… That is odd.

As Chris says .sat should work with AutoCAD but so should the other models/formats.

The ShrinkTrimmedSrf command trims all the surfaces back to the boundary so there shouldn’t be any other geometry. But, if you turn on the control points you can see that the underlying surface is still there.

Are you exporting an exploded surface or a joined model? If you’re exporting a model in it’s component parts, that could be the issue.


#15

Well Shrinktrimmedsrf isn’t going to help with the bottom, it only shrinks things down to the smallest possible rectangular surface.

If this CAM can work with Inventor models–I mean, does it? What sort of stuff do you make in Inventor?–then surely it has some ability somewhere to respect the trim curves, that’s what every solid modeler will spit out.

CAM in general should definitely be able to work with trimmed surfaces, and not care so much about ‘watertight’ solids.


(David Cockey) #16

ShrinkTrimmedSrf shrinks the surface to the the smallest set of untrimmed surface isocurves which encloses the trimmed surface, and then trims that surface if needed. The shrunken untrimmed surface will be a rectangle in UV space but may or may not be a rectangle in physical space.


#17

Yeah, that’s true, but its unclear what going on here. I just wonder if having a solid that is recognized on the receiving end will make any difference at all.


#18

Surely this is just a problem with the CAM software, have you contacted them? I exported the parts using DWG and opened in Fusion and there’s no problem getting the correct toolpath.


#19

cdordoni - I have tried dwg, dxf and sat files but no noticeable difference between any of them. When I open the model in Genio I have to use the explode command on the model. If I don’t explode it the whole object can only be selected rather than just the surface I’m looking for.

2DCube - The way I’m exporting is type in export select just the layer I want and then hit enter, I’m not sure what you mean by exploded surface or joined model?
The export option for dwg/dxf is set to “2004 Solids” in case that makes any difference? I originally exported it with the default settings but when opened in Genio or AutoCAD the surface boundaries were only showing up as splines with nothing between them.

JimCarruthers - I don’t do a whole lot of 3D work with this CNC and CAM package but generally it would be simple enough shapes created in Inventor, as in lofts or sweeps with some curved profiles. I draw these as solids, no use of surfaces at all so this model would be the most complex I’ve tried with Genio.

It doesn’t have to be a solid for Genio, if it comes in as a solid it has to be exploded anyway.

davidcockey - Thanks for explaining that to me

Hughes_Tooling - Yeah I think you could be right about Genio, I know it’s not a great package but I was trying to make this work if I could. I have already been looking into Fusion and have created some trial programs including this model, but I’m having some issues with the post for my machine at the moment. I’m in contact with Autodesk and will most likely switch over to Fusion in the future but at the moment I’m making do with Genio till I get a post working correctly.


#20

Then I would suggest making solid for each surface you desire and import them as separate files. This should not be necessary, as has been stated by others. However, trouble shooting often requires doing things that don’t seem necessary.