Exporting from rhino to blender by object

Hi Everyone,

I’m trying to export a lego car I made in rhino to blender. There are tons of format that convert my nurbs into a meshs model but most of them convert it in a single mesh and doesn’t convert it in individual mesh, only the .fbx format seems to allow to do that. the problem with the fbx is that it creates weird armatures links in blender when i import it, it’s easily fixable but I was wondering if there wasn’t a more appropriate format or setting that I’m missing here.


I actually just find the solution, while exporting in .OBJ, in the option → in the formatting tab, the ‘export rhino object names as’ should be: ‘OBJ objects’ instead of ‘Do not export object names’

1 Like

You could also try my GitHub - jesterKing/import_3dm: Blender importer script for Rhinoceros 3D files importer add-on, see if it works as you need it.

1 Like

Hi Nathan,
thanks, it could be a solution, how do I install it? I always struggle to understand how to use GitHub files…

Load the correct ZIP file from Release import_3dm v0.0.10 · jesterKing/import_3dm · GitHub

Read and follow the installation instructions. Don’t forget the installation note from the first link in this post…

thanks, it works.
Maybe it would be nice to be able to control the mesh quality of the nurbs convertion.
And curves are very unacurate, but I guess that it is because blender doesn’t manage nurbs correctly… a solution I found is if I want to import a curve from rhino to blender, I first convert it as a 1degree curve with more points into rhino, it’s not ideal tho.

The add-on does not create the meshes, it uses the meshes that were created by Rhino. You get exactly those. That is why you need to save with shaded mode or rendered mode active. If you need higher density meshes you need to set that in your Rhino document setting and switch to Rendered mode before saving your document.

The rhino3dm Python module used does not have meshing capabilities. And curves are experimental at the moment :slight_smile: