Exported into illustrator, closed Rhino, re-opened rhino and all hidden layers are gone

grasshopper
(Dmmohlman) #1

Went to export line work from rhino into an illustrator file, saved and closed out of rhino, opened illustrator and was missing some layers, reopened the rhino file to find all of of the layers I had hidden have disappeared.

(Alvanroo) #2

I have had the same issue with the Mac V6 WIP. Any ideas how to resolve this?

(Wim Dekeyser) #3

Hi - so far I was unable to reproduce this issue.
Could you provide more details about the workflow and perhaps a 3dm file that we can test with?
Thank!

(Alvanroo) #4

Hi there, Sorry for the slow response. I’ve made a little video by recording my screen. It shows the steps I take to make the issue occur. I’m not sure how to send you the video as its 46MB after compression. What’s the best way to get it to you?

(John Brock) #5

I think this is fixed:
https://mcneel.myjetbrains.com/youtrack/issue/RH-51620

(Alvanroo) #6

Hi John,

I just installed the latest WIP and tried it again, still have things disappearing. It seems to be an issue with exporting parts of a drawing and then saving when prompted after closing the window. I lose all layers and anything that wasn’t exported.

(John Brock) #7

Hi
A video won’t help us.
Can you please send us the 3dm file and the specific command sequence you follow to reproduce the problem?

You can send the file to tech@mcneel.com with those instructions and also please include this URL: Exported into illustrator, closed Rhino, re-opened rhino and all hidden layers are gone

If the file is too big to attach to a message, maybe stage it on GoogleDrive/DropBox/etc. and send us a share link

Thanks

(Alvanroo) #9

File sent. I hope it works for you. Please let me know if I can help with anything else or if the file didn’t come through proprerly.

(John Brock) #10

I was able to reproduce this using the current WIP.
I’ll get this example to the developers.

However, if you Save the current file first with all the objects, then export one, and Quit, then when I reopen the file, everything is still there.

(Willcox16) #12

This kept on happening to me when exporting selected to illustrator. Especially if I saved afterwards with the exported linework selected. I now copy what I need to export to another file to avoid the issue.