Export to Illustrator CC 2014 fails

Hi! I am wondering if this is a personal problem, or whether more people are experiencing this: I recently updated my Adobe CC Suite to the latest version (2014). Now, when I try to import simple lines from Rhino (exported as AI) it won’t do and give me an empty document instead. I tried this with several documents - all with the same result.
DXF and DWG will be read, but each line segment is separate then…
Is this an Adobe bug, or can I do something different?

I just did a test. Drew a few rectangles and circles, select everything, go to File> Export Selected.
Opened with Illustrator CC 2014 and everything was imported properly. Have you checked the scale?

1 Like

I guess this is because the unit setting doesn’t match or not close between ai and rhino…

Strange - I now also drew some simple rectangles and circles in a new file and still get this message:

AI Version 2014.1.0 - 18.1.0
Rhino V5 SR8 64-bit

These are my files:
Error.3dm (29.7 KB)
Error AI.zip (10.3 KB)

Not sure about the units - why would it matter?
I use mm in both Rhino and AI and export with “preserve model scale” and “export viewport boundary” enabled, but the error comes with any setting. My tolerance settings in Rhino are nothing fancy too: 0.001mm / 1% / 1°

I tried to open the exported AI in Acrobat XI directly with no sucess … also placing in InDesign will not work.

Reinstall Rhino?

The File doesn’t open in Illustrator CS5, either. This looks like a locale mismatch on writing the file.
The decimals in AI files should be delimeted with a . whereas your file was written with the german , delimiter.

Since this is a file written with Rhino, please state your Rhino and System configuration, especially the language settings.

My Setup exports correct AI files:
Windows 8.1, 64bit, German locale, English language installed
Rhino 5 SR10 64-bit (5.10.41015.17045, 15.10.2014), English locale

Hi Okrim - most likely, you are seeing a problem that is caused by iCloud - do you have this installed? Please see this thread for a discussion of the problem and how to fix it -

We are working on a fix for Rhino, it will be in SR 10 - this problem has delayed release of SR 10 but it should be quite soon- you can get the SR10 release candidate by setting Options > Updates and Statistics > Update frequency to ‘Release candidate’. Once you have this installed, use the testDecimalPoint command to fix the locale problem. Or, completely uninstall iCloud, if you have it.


Thanks Pascal
I have iCloud installed. Will uninstall tomorrow and wait for SR10 then.


-If I open your AI file directly, I shows the error window
-Reexport from Rhino as AI format, it works.

I uninstalled iCloud - and Rhino is exporting correctly!