Illustrator gives error while opening exported Rhino work

unhandled

#1

Hello,
I’m trying to export and edit lines I’ve created with Rhino, on Illustrator. I select the lines and choose export selected, then choose ai format.
But when I open it, Illustrator gives an error that says,
“Can’t open the illustration.The illustration contains an illegal operand.
Offending operator: 1,0000
Context:
%AI5_BeginLayer
1 1 1 1 0 0 -1 0 0 0 Lb
(Default) Ln
0 A
0 R
0,0000”

I’ve tried to uninstall and reinstall both programs with different versions. And I’ve tried opening different files. I’ve tried to open the Illustrator file as text and changing the text. Also I’ve enabled document recovery for Illustrator still nothing has changed.
Why is it giving this error and how an I solve it? Thank you !


#2

Try this:


#3

Is there anyone with this problem?


#4

Hi,

I export curves to Illustrator CC 2014 pretty frequently, and have not had a problem.

I always choose to export snapshot of current view. I tried exporting it at scale just now and ended up with a blank document. So I would recommend exporting the snapshot of current view, if you haven’t tried that already.

Good Luck


#5

I’ve tried that but thank you :slight_smile:


#6

Did you read and try solution in the link, I posted?


#7

Yes I did, I can export DXF or DWG but lines are seperate and still can’t export .ai
But it has helped so far


#8

I don’t see where your problem is in any way related to exporting DWG/DXF. The OP of the related post just mentioned that he could export those successfully…

Let me summarize:

  1. other people have the same (or similar problem) as you have.

  2. the error message shows that your file contains a “,” where it should read “.”

  3. that error occurs when writing the file with a wrong locale setting.

  4. all other users with that problem had iCloud installed

  5. deinstalling iCloud fixed the problem!

…6) there are several other locale related problems when iCloud is present. There may be a fix with the current SR10 but I cannot check.


#9

Yes problem is fixed after iCloud is uninstalled, thank you!


(Pascal Golay) #10

Hi Gizem - I think SR10 should work with iCloud - though you might need to run TestDecimalPoint - I’ll confirm, I can’t remember off hand if it (SR10) completely works around the problem, or if you still need to run that test command.

-Pascal


#11

From my experience it is important to make sure the curves you are exporting to Illustrator are at origin 0,0 or at least the center of your image is located 0,0. If you have a drawing way out on the x/y axis nothing will appear.
Hope that helps.

-Rupert


#12

El problema sucede cuando se aumenta el factor de escala o eso me acaba de suceder, no me había fijado y aumente el factor de escala y eso no permitía a Illustrator reconocer las líneas. Debes revisar el factor de escala disminuirlo si es el caso y no habrá problema de compatibilidad.