Export size issue

Hello,

I have an issue while exporting my file from rhino to robot. Previously it worked fine when I did my drawings in meters. Now I have changed my drawing unit to mm. All my units are now 10^3 too big when I import my file to robot structural analysis. PLz help

-Niklas

The export is otherwise correct but the loads and sizes of elements are wrong. Elements are in the right cross section but they are too long. I noticed that this change occur when I changed the karamba settings component from m to mm, but for some reason it doesn’t change the export file to right format. I tried to change the karamba.ini file as well.

Hello @Niklas2,
do you use the latest service release of Karamba3D (see here: Releases · karamba3d/K3D_NightlyBuilds · GitHub)? In version 2.2.0.17.2 there was a fix for a units conversion related bug in the DSTV-exporter.
– Clemens

When you change units in Rhino (‘View | Display Options… | Units’), this scaling dialog box should appear - click “Yes”.:

By updating both karamba and rhino to the newest versions helped. Thank you!