Export Selected and isocurves

If I am in a view mode with isocurves disabled, the Export Selected command will still export some isocurves to Adobe Illustrator format, the ones that are visible on selected surfaces regardless of what the viewport setting is. The screenshot below shows two identical surfaces, with one selected to show the extra isocurves that appear; the second screenshot is the exported AI file. While there are workarounds (ExtractWireframe, Make2D,…), it would be an improvement if the export was based on the user’s chosen display settings and not on whatever display mode is used for selected objects.

I tried the same with an SVG export and, while the isocurves are visible in the export preview, they are not actually exported to file, so this behavior seems to be inconsistent across export formats.

This is on Rhino 6 SR29.