Exploding text is broken


#1

Hi,

If I create a text with the Text tool and then want to explode it down to curves, the curves does not match the text.

Best regards


#2

Is that with all text fonts or just that one? Seems to be working here with a couple I tried at random…

–Mitch


#3

Works here:


(Wim Dekeyser) #4

It’s font-specific.
A font that I use often also behaves badly and I’ve always disregarded it as a problem with that specific font.
This topic now made me check a bit more: I used the same font in Inkscape, exploded it, and exported to PDF. Then imported the PDF into Rhino.

The upper most is text in Rhino. Below that is the same text exploded to curves. At the bottom are the imported curves from Inkscape…:

It’s obvious that Inkscape does a much better job in converting the font to curves so there should be something that could be done about this in Rhino…


#5

Did You check with Solid>Text>Curves ?


#6

Fonts are notorious for having bad curve definitions - they are made for print, not for manufacturing. Illustration type programs may well be better at dealing with these bad definitions.

–Mitch


Nasty text explosion
#7

This one workes in my example case. Thanks!


(Pascal Golay) #8

Bjorn, what font is that? Does it make any difference what the scale is or file tolerance? I don’t expect so, but, just checking.

thanks,

-Pascal


#9

Hi,

That was a variant of Univers. No, I tried scaling it but it did no difference. TextObject tool worked though.


(Wim Dekeyser) #10

I agree - and that is why I have disregarded the issue in the past.

But it is interesting to see what TextObject does!


It seems like the start and end points of the paths are open in the font definition. Obviously Rhino can deal with it (and could possibly also automatically put in an extra line) but somehow it ‘forgets’ this when exploding text.


(Willem Derks) #11

Hi Wim,

In your last example, was “allow single stroke fonts” checked like so:

If you uncheck that do the curves come in closed?


(Wim Dekeyser) #12

Willem,
I’ll have to check that last part when I’m behind a PC (if I remember tomorrow 'coz as you know there is no 'mark unread:).

As for the former, yes, that was checked. That I remember since the command retains settings across sessions and over a year ago I used an engraving font…


Exploding text problem. Any workarounds?
(Marc Gibeault) #13

You can add a bookmark to be reminded!
And since I replied you’ll see a “new” message in the top of the page.


(Wim Dekeyser) #14

Willem,
If unchecked, yes, the curves come in closed.


(Lowell Walmsley) #15

Without looking carefully at a specific case, I think its because of missing closing segments in some truetype character definitions as has been suggested above.

It’s legal to have a truetype font contour that’s not explicitly closed and the last segment is added when the charater is rendered.
The TextObject command deals with that pretty carefully. The checkbox about single stroke fonts disables adding the last segment so that special purpose fonts that meant to render as curves and not filled areas for machining, etc work as intended.

It looks like a bug in text explode that the closing segment isn’t added when it’s missing, but instead the last point of the last segment that is there is moved to the start of the contour.


Nasty text explosion
Equivalent of TextObject in RhinoCommon