Essential Shortcuts still missing

i am getting the feeling that nobody actually ever worked with mac… please dont misunderstand that but these f keys can be activated in the mac os settings to work as actual f keys, besides that you can also deactivate individual keys in the settings so that is absolutely not an excuse. also those buttons have worked before and now all are working besides the f11? so i dont believe how much this is becoming a pain

as @Gijs found out that steve was wrong about it

now you come and tell me that f11 is the only key which is not possible due to the same reason steve already was mistaken about. so what is going on, can you guys please gather and discuss that and involve mac experience people, i mean people who work for more than 25 year on mac like me or anything anybody reliably similar experienced?

it simply can not be that this is such a fuss and a battle with those shortcuts.

just in case you still dont believe me

here i have deactivated the key for mission control functions entirely because i simply do not use it like many others and please leave that to the user to decide how they want to use the function buttons.

who want to have the entirety of f buttons available
activate them as seen here below.

i am sure that nobody believes how such changes which are totally unfounded are plain infuriating…

I was mistaken; people do make mistakes. We are fixing these shortcut keys.

1 Like

please tell me what i can do better to mitigate such topics.

You did nothing wrong. I was mistaken about the ability to disable keyboard shortcuts from the OS keyboard settings page. New service releases and next SR release candidates are planned to be published on the second Tuesday of every month. 8.5 release candidate 1 should be available on Feb 13.

1 Like

Perhaps this has already been mentioned in this lengthy discussion, however, I would like to add a serious and trivial issue that I am having with keyboard shortcuts (Rhino 8 Mac).

It appears that some keyboard shortcuts, for example in my case (however there are likely more) F8 (the same issue is present with many others but I will not mention them for the sake of clarity in explaining).

I have overwritten the F8 command in the keyboard settings to produce the command “Join”. The program however refuses to execute the Join command and simply continues toggling the ORTHO On/Off (which I presume was the original command before I modified it - this also happens for a number of other shortcut commands where the original shortcut command continues to be executed despite having been changed).

This to me appears to be a simple, highly dysfunctional bug where a user is given choice to customise their workflow and the software simply does not function as advertised and expected. Please let me know if this is a widespread issue and if any fixes are underway. Thank you for your work McNeel staff.