Error when loading 3dm file: Unreadable geometry


I have tried to open file recently saved however got the following error:

" …3dm has an unreadable geometry object. Do you want to continue reading geometry from this file?"

After I confirmed yes - I have a following message:

“…3dm has an unreadable history record table. Do you want to continue reading?”

After saying yes - I am getting the whole structure of the layers but no any objects. However it shows me still the size of about 37 MB.

I have also checked Rescue3dmFile - however doesn’t help.

Any other hints or should I consider a file as lost?

Thank you in advance,

Hi Dmitry- I would consider the file lost, I’m afraid, if Rescue3dmFile does not find enough to be useful. I would check for a .3dmbak file of the same name in the same folder and see if that will at least help in recovering the info. I assume you used the Recover option on Rescue3dmFile, and ReadAll? Can you tell what entity it chokes on? If so, you might be able to use the Skip option. No doubt you’ve been through this but see Help for details on the command to help you try to recover at least parts of the model.


Thanks Pascal,

I have tried 3dmbak and it works with a bit of lost work as it has been saved a bit earlier.

Anyway, thanks for support!