Error unrolling surface from 2-curves


I’m using an evaluation copy of D.LOFT on a Rhino 5 windows machine. I started with a boat hull that I developed free hand before I got D.LOFT. Both the hull side and bottom surfaces of that model would unroll in rhino.

I used that to develop edge curves. D.LOFT would not successfully use those edge curves. I did small changes to the edge curve and it worked well for the hull side surface. I’m getting a good curvature map and the surface unwraps as expected.

Not so with the bottom surface. I have to use some of D.LOFT’s options but I do get what appears to be a usable surface. When I try to unroll it, however, I either get an “error unrolling surface” message from Rhino or in some cases with minor curve manipulation it will say “one surface unrolled” but it doesn’t obviously show that it has done so. With a closer look it has unrolled only a tiny piece of the surface which I can find if I turn labels on.

Does anyone have a thought on what I might be doing wrong?

chuck .

(Alexander Schiftner) #2

Could you post your example here? A problem that has occurred to me before is if the lofted curves end in a common point. In this case Rhino sometimes has difficulties to unroll the surface resulting from D.LOFT. A workaround for this is to chop off a tiny piece of the surface tip.


N26 sample.3dm (280.1 KB)

Hopefully you will find attached the two surfaces in question.



I tried to upload to the forum. Maybe I was unsuccessful. Attached are the two surfaces and the edge curves I used to create them.


N26 sample.3dm (280 KB)

(Alexander Schiftner) #5

It’s the problem I expected: Rhino has difficulties unrolling the lofted surface which ends in a single point:

A workaround for this is to delete the first pair of control points:


Thanks for the help. It would have taken me a while to stumble into that solution.


(Alexander Schiftner) #7

It’s on our list to improve this, we are thinking to make the workaround part of the plug-in (as an option).