Error opening 3DS file


#1

Hi!

I was working with a scene in which I was importing some 3DS geometry, then, I updated Rhino to the latest version, and now I can’t import 3DS files. The files are okay since I could open them with Sketchup and with 3DS Max, and when I export them from Max to Obj, I can import them correctly.

When I try to import a 3DS file this message eppears: “Error opening 3DS file”

Anyone else has this problem? Anyone knows how to fix it?

My Rhino version is: 5.9.40609.20145


(John Brock) #2

Can you send us a simple 3DS file example that illustrates this problem?


#3

It seems I am not allowed to upload a file with the 3ds extension, so I am going to upload it with another extension:

Drum 3 N220210 - Copy.3DS.dwg (304.5 KB)

I am starting to think this happens when you directly drag and drop a 3ds file from a compressed source (zip file opened with 7z) into rhino. Some, if I extract them to a normal folder before and then import them have no problem, but if I drag it from a compressed source, it kind of messes up and won’t allow to import a 3DS from a normal location. I have to open another session of Rhino for it to work.

I think I actully solved my own question. The interesting thing is, why Rhino won’t let you import again from a normal location if you tried importing from a compressed location first?