Error ‘could not find node…’ even if support is defined as endpoint of beam

Hi all, I am new to Grasshopper and Karamba 3d and I am having some difficulties in assembling a structure for the analysis.

In particular, when I connect the supports to the Assemble model, I get the following error:
‘Could not find node at (x, y , z) where supports number 0 is attached’

I did some research online and found that the supports should be defined as either endpoints of beam elements or vertices of shell meshes.
However, even if I define the support as end point of beam elements, I still get the same error. Attached is the gh file. (147.8 KB)

I would be really grateful if somebody could advice on it. Many thanks in advance.

Dear Luca,
you forgot to internalize the geometry. The input points in your definition are all null.

Dear Clemens, thanks for your response.

When you said that I forgot to internalize the geometry, could you please be a bit more precise? I have tried to internalize the support points but I still get the error.
Also, my origin point is already linked to one point in Rhino.

Thanks in advance,

Hi Luca,

Exactly that is the problem:

That point is only available when you also have the Rhino 3dm file. To avoid that, you internalize that point by RMB clicking on the Point component and picking Internalise data.


Dear Wim,

Thanks a lot for getting back to me and apologies for my late reply.

Which points should be internalised?
I have tried to internalise the origin point and the 4 support points of my structure, but I am still getting the same error.

Apologies for the questions but I am new to Grasshopper and Karamba.

Thanks in advance,

Hi Luca,

Basically anything that is in your Rhino document. You are posting the gh file only, so any references to Rhino geometry should be internalized.

Internalizing will not solve anything for you. It’s a step towards others being able to help you. No one can help if they don’t have the same information as you have…

ASB_v2.3dm (19.9 KB) (149.5 KB)

Thanks a lot for the quick answer Wim.

In my Rhino file I have defined only one point (the origin). All the rest is just defined in GH. If I internalise that point (origin), I still get the error… It would be really great if you could have a look and see what I am doing wrong…

I attach both the Rhino and the Grasshopper file.

Thanks again for the help.


Hi Luca - I don’t have Karamba installed. I was only trying to help with the internalizing of inputs. Hopefully, you have provided enough information now so that @karamba3d can take a look.

Hi @luca.costa,

i am not sure if your definition is complete, but the supports are not connected to the model. I can see that you have not flattened the inputs for the Elements in the Assemble Model component. It is suggested that you flatten all the inputs in the Assemble Model (Elements, Supports, Loads, etc)


Dear Matthew,

Thanks a lot for the big help. By flattening the inputs I don’t get that error anymore.