Environment Lighting Not Working Properly In Raytracing or Rhino Render (No Lighting/Shadows)

Hello! I’ve been following along with a couple of Rhino 7 rendering tutorials but I am not getting the same result when it comes to the use of environmental lighting. According to one of the tutorials, to light your scene with an environment image, it’s as simple as opening the Environment tab, clicking Importing from Environment Library, selecting one of Rhino’s built-in environment images then right-clicking the new environment and selecting Set as Global Environment. This seems to change the colour of my scene according to the specific environment but when I do a Raytraced render or use Rhino Render the lighting is not right and I’m not getting any lighting/shadows, as seen in my screenshot below. I’m rendering with a RTX 3080 using the CUDA setting in Rhino (Optix does not seem to work for me). And the only lights I have in my scene are the default Sun and Skylight (Sun is off, Skylight is on).

Is there any way to get proper environmental lighting in my renders? Thanks!

HDR/EXR images which are used for image based lighting will have differing dynamic ranges. Try some other ones like Incheon Airport or Blur Loft to see more defined shadows. If you want darker shadows after that, you can use post effects like tone mapping and brightness/contrast in the Render window. Or use actual lights in unison with image based lighting.

Hi, Brian. With each environment I choose, I get the same even and soft lighting. I have the Haleakala environment in my original screenshot, which has a clear sky and direct sunlight, so the lighting and shadows on my model should be strong and obvious. I tied the Incheon Airport as you suggesting and I get the same soft lighting - in the screenshot below, you can see the discrepancy between the lighting on the floor and chairs of the background and the lighting on my model.

Here’s another example: BCN Airport Deck, which is in direct sunlight, yet the render produces inaccurate even/soft shadows.

The shadows seen in the image itself are not going to be the shadow intensity you’ll get in the rendering exactly… at least not with the level of dynamic range I was able to capture through three exposures when I shot these panoramas. You can try other HDR equirectangular panoramas by adding them to any new basic environment. Or use the suggestions I made before to increase shadow darkness or use actual lights as well.

You can try this library for instance… HDRIs: All | HDRI Haven just drag and drop into the Rhino viewport and choose to load the HDR automatically into a new environment.

Hmm, I see. Thanks for the tips. Unfortunately, it seems Rhino does not have the same environmental lighting capabilities of other software I’ve used where what-you-see-is-what-you-get, regarding the lighting - ex: if it was a sunny day in the HDR, you will get lighting and shadows exactly representative of that sunlight all in one HDR. I guess Rhino’s environmental lighting is mostly useful if you have reflective materials?

Hi @Ando,

Skylight comes from all directions and fills in shadows. If you want hard shadows you need to have the Sun turned on. Then turn down the Skylight to increase the contrast to what you want.


Thanks, Jeremy! I will give these settings a try.

I have a bug report on my todo list that has to do with this. You should be able to get sharper shadows especially with environments that have a large dynamic range (very high-power spots)

RH-61976 HDRi with high dynamic EV are underpowered in Rhino Cycles

I don’t know yet when I’ll get to this.

Hi, Nathan;
I’ve got something rather odd to show you: the final rendering is quite acceptable but what shows up on screen in rendered view is odd to say the least…

Skylight in Rendered mode is something that @DavidEranen knows about, I’ll have to defer to him for that.

Great to hear! Thanks for your efforts.

RH-61976 is fixed in the latest Rhino 7.7 Service Release

you should really figure out why it does not work for you. with optix enabled, your RTX3080 will render way faster compared to just using CUDA. do you have the latest driver installed?

I suggest you use the latest studio driver, currently version 462.65. btw, this is the standard driver version, don’t use this if you had the DCH version installed before. if you nvidia control panel is installed via the microsoft store, then you have the DCH version, if not you have the standard version. stay with whatever you have so far, don’t mix. here is the link to the DCH version.