Enviroment lighting always casts shadows


#1

I’m not sure if this is the desired result, but if I untick the Casts Shadows of an object’s properties, it still casts a shadow from environment lighting, but not other lights like spot lights.

This is a real problem with glass because the only way I’ve been able to get light to go through glass properly is to turn off shadows for the glass panes.

This works in Blender, but not in Rhino raytraced viewport:

You can see in Blender, inside the glass box is illuminated, but in Rhino it has shadows.


(Pascal Golay) #2

Hi Gavin - what is the material? Is it a built-in Rhino glass material? In a quick test here I see this:

That is what you expect, right?

-Pascal


(Nathan 'jesterKing' Letwory) #3

This indeed is a bug. I am currently working on this.