"encountered an improper argument"

Hello, I am having an error message when I open a file and it will only allow me to look at the model but none of the commands will run. I am able to start a new file and work like normal but once I save, I get the same error and the program will not close. If I try to open rhino by clicking the file, it will crash. I am running Windows 7 pro, SP1, windows is up to date. Any help is appreciated. Thanks in advance.

What Service Release of Rhino are you on?
Have you tried reinstalling?

I have SR 13 and I have reinstalled multiple times but issue remains.

Do you have any non-standard plug-ins installed? Does Rhino start in safe mode and allow you to save anything?


Yes I do have non standard plug-ins, but I have disabled them and also have tried in safe mode and same results.

UPDATE: So I had to do a fresh install of windows 7 and had to reinstall my programs. I did not lose any files but just the hassle of reinstalling programs but Rhino finally works again! I guess there was a windows file that was corrupt and caused the error.