Ellipsoid wire frame with missing lines

Hey,

I’ve made an ellipsoid from 2 ellipses with RailRevolve and divided it with a grid using ProjectCurveOntoBrep. Then I found the intersections with CCX and connected it with a polyline - saw the solution on the forums.

So far so good but when I took a look at the wire frame I saw that it is not complete. There are lines missing and some connections are not correct (see pic)

Any idea how to solve it?


palicje-elipsoid 3.gh (34.3 KB) palicje-elipsoid.3dm (2.6 MB)

Hi,

this is not 100% accurate, but it might give you some clue…

palicje-elipsoid 3_RE.gh (46.6 KB)

Hi,

thanks for the help @Jakinta. How did you achieve a complete wireframe as in the screenshot? When I open your edited file, the geometry still has mistakes …

Please, check the white group in file, whatever i have edited is in there.
I had some trouble with mid-Y-axis-plane section, so i had to reconstruct that polyline separately. Have used your existing vertical lines. They are not synchronized with newly generated polylines, hence my note about inaccuracy.
Still have an impression this should be done better somehow…

Here is the new version…Check red and green groups…

Elipsa%20%201

palicje-elipsoid 3_RE_v.2.gh (42.9 KB)

Wow thanks. Didn’t think about using contours …

Is this the part that connects the intersections on the base ellipse with the contours cause I get zero intersection and I double-checked the inputs (maybe it has something to do with Grasshopper versions, I have an older one …)
26

No, that is the part for creating horizontal “beams”.
Blue lines in your picture are created within Polyline component, after Sort Along Curve.

Aha, so then there is something wrong with the intersection between the ellipse and extended planar curves. I’ve got zero intersections …

It works on my computer.

It seams that you messed up something with data structure previously in definition.
You can see dashed wire for A input in my file, in yours is solid i.e. flattened…it shouldnt be…

Hmmm … thats strange … I didn’t modify your file, also tried it on a different computer with the latest Rhino version and it’s still the same. Even if I try to recreate the formula in the file the CCX just doesn’t work

hmm…strange…i have reopened the file saved on my hd, same problem as yours occurs… :frowning:

It was related to rounding of Z-coordinates. Project those extended lines to XY plane and it is solved.

palicje-elipsoid 3_RE_v.2_again.gh (44.0 KB)

Try to make it simple from the beginning

palicje-elipsoid new.gh (41.7 KB)

1 Like

@Jakinta, @seghierkhaled thanks a lot! Both formulas work. :slight_smile:

I started from lines because the axes in X direction are fixed on those 8 double pillars (red colour in the file). Thats why I didn’t divide the length with number of segments but added new axes between those static ones

Do you maybe know how could I formulate that the X lines would generate like that? I tried with scatter but the lengths are wrong

10