Edges of curved surfaces come out as straight

When I split and trim surfaces to make them curved surfaces it comes out as clipped and become straight , how can I make it so these voids go away and have a solid surface

That’s just the render mesh. You could up the mesh settings so that they aren’t so visible, or for a more elaborate solution you can Join up those surfaces, manually Mesh them, then Explode them so that you get separate, aligned meshes.

To add to Jim’s reply, Rhino austomatically creates meshes from surfaces which are called render meshes and uses those meshes as the display of surfaces. The graphics calculations to display the meshes can be much faster than trying to do the calculations using the NURBS geometry directly. When you zoom in closely eough you see the straight edges of the render meshes. Altering the settings in Options > Document Properties > Mesh to cause the render mesh to be finer will eliminate the apparent gaps. For more information see Rhino Mesh Settings - Detailed Info [McNeel Wiki]