Echo is not working


#1

Hi,

We are using the below scripting command. I specified “echo = false”. But it’s not reflecting while running our application.

bool isSuccess = Rhino.RhinoApp.RunScript("_-Export " + filePath + " Enter", false);

Thanks,
Pushpa


(Dale Fugier) #2

Hi Pushpa,

The echo parameter only work to suppress ‘get’ generated prompts. It does not suppress messages printed by commands - calls to RhinoApp.WriteLine() for example.

If you are trying to hide the results of scripting a command, you might consider clearing the command history windows when your scripting command finished. You can do this by calling RhinoApp.ClearCommandHistoryWindow().

– Dale