Rhinoscript Command blnEcho not working properly when scripting Export and Import

The title says it all.

I am scripting Export and Import commands from GHPython.

But the blnEcho option when scripting those two does not work the same like when scripting other commands.

rs.Command("_Sphere 0,0,0 5 “,False)
rs.Command(”_SelLast “,False)
rs.Command(”-Export " + file_name + " x e p e" + " _EnterEnd",False)
the command prompts are visible in rhino in the export step.
** file_name is a path …\test.obj

As opposed to doing this , rs.Command("_Point 0,0,0 ",False) where no command prompts are echoed, as it should be.

Is this normal?

Hi @SherifTarabishy,

Yes this is normal. The blnEcho parameter suppresses command prompts. But it will not suppress print statements made from within commands.

– Dale

Thanks for your reply @dale
One other question that is a bit related, when using this method to script commands, if I want to “set” command line toggle options to a specific state, rather than toggling them every time I am accessing them, is there a way to accomplish that?
So for example rs.Command("_Rotate c “,False) would toggle between Copy = Yes and Copy = No, is there a way to make sure the value is either all the time?

Figured that out, just for reference: