Downgrade Rhino WIP

Hello everyone,

I have a problem with Rhino WIP.

After the latest update, a grasshopper file I’ve worked on for the last few months no longer works the same way.

Long story short: I’m running some rigid body collisions and stuff using kangaroo - nothing too crazy. It was running fine until the update. Nothing else changed. However now when I try to start the kangaroo simulation Rhino crashes, shows me the sad rhinoceros with the deflated beach ball and I can’t do anything.

If I switch to Rhino 7, things work again, but way slower than in Rhino WIP.

I tried using Windows system restore as a way to recover and chose the RhinoWIP restore point - it said it would remove the current WIP build so I thought that would be enough. However after restart I noticed the latest WIP was kept.

Rather than getting helped with a file which already worked (and still works with Rhino 7), I’d truly appreciate if anyone can suggest how to downgrade my Rhino installation to the one prior to the 20th of this month (yesterday).

I need to continue working on this, at the speed I had just a couple of days ago before the update on the 20th.

What are my possibilities? Serious matter.

Thank you for your attention

Maybe someone will do something for you but using “WIP” software, not even “Beta” yet, for actual work is absolutely entirely at your own risk. If you can’t live with some new bug actually destroying your data–nevermind some thing not working as fast as it used to–and possibly setting your printer on fire, don’t use it.

Ok.

Here:

You did something!

Fueled my desire to:

  1. continue using Rhino wip
  2. delete this post

Hi René -

I’m not seeing any crash reports from you.
The previous public release of the WIP is this one.
Note that if you don’t provide us a way to reproduce the crash, chances are that this is something that won’t get fixed …
-wim

1 Like

Thank you @wim ! I will reproduce the error and generare a report. I guess that’s different from sending the files right? If you need them I’ll send them too, or the crashdump file. Thank you again and I will get back with that soon today.

Best

Hi -

There’s only so much that a developer can find by looking at the crashdumps. The best way to fix things is to have the files and workflow so that the developer can reproduce the crash in debug mode.
-wim

Also the output from Rhino’s Systeminfo command.

Thank you @wim !

Ok, I’m in front of the machine now and will downgrade Rhino WIP to keep working. I’ll let you know if the bug persists even after that.

In the meantime, I’m providing some files in this reply.

I do not know how to obtain the crash report but I clicked ‘send’ after it happened.

Check the screengrabs below.

Rhino WIP attempt:

Rhino 7 attempt:

Both times I used the same grasshopper file:
ic09.gh (185.8 KB)

*edit note: rhino units were inches in case it matters

*again: I clicked on ‘send’ for the crash report and put in my email. I’m not sure that gets you the needed material. Let me know if I need to generate something else.

Sure thing:
7222022.txt (3.1 KB)

Thank you for your help!

Ok just reopened the file with the previous wip release and the simulation worked fine like before (and faster than R7) with the same grasshopper file.

Odd! I trust it’ll provide some clues!

Thanks once more for your assistance!

Hi @corellaman,

I am able to reproduce the crash. I’ve logged the issue.

https://mcneel.myjetbrains.com/youtrack/issue/RH-69535

Thanks for reporting.

– Dale