Double clicking text> shows "delete annotation style?"


#1

in the latest WIP double clicking text in viewport > shows "delete annotation style?"
then when I click no, the text properties window shows as expected.

cheers,
daniel


(John Brock) #2

We are aware of this problem and working on it.
It happens when a new RText style text has an override, and is copied and another override is added.


#3

i see, interesting i did not notice that.
It seems because i opened a rhino5 file which might have had some additional infos / styles in it.

because in that file, if i create a text object from scratch(no overrides set) it also happens.

*edit
when starting with a new empty default template in WIP, the problem does not show itself.


(John Brock) #4

Correct. Actually the problem is more structural and has to do with how all text and dimension settings are managed through named styles.

There are several bug reports that cover the specific details of the issue. Several developers are working on the problem.


#5

I reported this here, if you want to check if it covers everything you are seeing: Text override behavior


R6 feedback. Things I don't like
(Lowell Walmsley) #6

We’re in the process of making a pretty big structural change to handle overrides better. Maybe we’ll have something that works a little better next week. We’ll let you know