Dot Command Stopped Working

Running v6 SR31, and as far as I can tell, Dot has stopped working. If I run the command normally, the command completes without ever prompting for text or location. No indication of any error. If I run it with command line options ("-Dot"), I can enter text and locate as normal.

Strangely, I also cannot edit existing text dots in other files - the dot menu is available but completely blank in the properties tab when I select the text dot.

I have another machine with the same version installed and I don’t see this problem, so I don’t think it’s an issue of the release version. I’ve completely rebooted the machine to no avail. Any clue as to what’s going on here?

Moved to Rhino for Windows

Hello - please run SystemInfo in Rhino and post the results.


Rhino 6 SR31 2020-11-10 (Rhino 6, 6.31.20315.17001, Git hash:master @ ff08c426b1ef7d3a1c50a01e5e87220a68a9f815)
License type: Commercial, build 2020-11-10
License details: Cloud Zoo. In use by: Patrick (Kreysler & Associates)

Windows 7 SP1 (Physical RAM: 16Gb)
Machine name: KA-PM02

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro K4200 (NVidia) Memory: 4GB, Driver date: 8-4-2014 (M-D-Y). OpenGL Ver: 4.4.0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.4
Shading Language: 4.40 NVIDIA via Cg compiler
Driver Date: 8-4-2014
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino WIP\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” 6.31.20315.17001
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino WIP\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino WIP\Plug-ins\export_STL.rhp “STL Export”
C:\Users\patrick\Downloads\elefront422\elefront421\ElefrontProperties.rhp “ElefrontProperties”
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.31.20315.17001
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino WIP\Plug-ins\export_STEP.rhp “STEP Export”
C:\Program Files\Rhino WIP\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 6.31.20315.17001
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.31.20315.17001
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.31.20315.17001
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”

Hello - I do not expect this is related to Dots but I would strongly recommend updating the driver to the latest available from the nVidia website. The Notifications panel in Rhino should help - double click on the one suggesting you update.
Other than that, I would also disable Elefront in Options > Plug-ins page and then close and restart Rhino (important).
Does that make any difference?


We’ve seen these blank windows before. Check on your Windows updates as well as they seem to be associated with some libraries from Microsoft that need to be up to date.

Thanks Steve & Pascal. The Windows update seemed to solve it. Wasn’t a major update, but regardless, it seemed to do the trick. Thanks again, you guys are the best.