"Document User Text" tab doesn't open

Thanks again - so this didn’t happen in SR19? I’ll start there.
I filed RH-56254 for this bug.

OK, I just set up a spanking new MSI laptop with Windows 10 pro and my fresh Rhino install (latest WIP) already has trouble with the Dot dialog !!! JUST BLANK !!!

OSUI System.txt (2.3 KB)

The interface is BROKEN .

I just don’t understand why there’s not more people enraged about this !

I remember having issues with dialogues before related to V-Ray. Which V-Ray version do you use?

I wish I could point fingers at something else, but an earlier system info from Olivier shows no VRay installed on a system where he was having this issue. The bug seems very local to Olivier and his coworkers as I haven’t seen any other reports of this issue.

@JohnM do we have a test command to view all loaded modules for the Rhino process? Maybe there is a shell extension getting in the way that is specific to Olivier’s system

There’s nothing too “local” about my config, except I’m using Rhino in English and that my Windows 10 is set to French/French keyboard.

I remember there was at least another thread about this from someone not in France.

My guess is that there’s a bunch of people impacted, but not many bother to report.

As for me, I’m getting quite fed up to open a second Rhino instance to create my dot or text and paste it back in my model.
This is the middle-ages.

Ah ! This was the guy : Blank Floating Windows

We never heard back from the initial poster on that thread so I’m not sure if the fix that was made fixed his/her problem. I realize that there are many users that don’t report bugs and that there may be a percentage of users out there with the same issue that you are seeing.

There is definitely something specific about your config that makes this bug show up. Did you install any other software on this new MSI laptop? Did the laptop come with any “extra” bloatware when you got it?

Wait a minute, let’s be factual here. It’s not about “my config”.
This happens in our engineering office where people have various types of desktops (Dell, HP, locally integrated), and on at least three laptops (Alienware, Asus, MSI).
The engineering office is in the East near Lyon, and the laptops in the West, near Toulouse.

Simon Worhamer who also reported the issue is in Germany.
He fixed it by re-installing Windows. That should give you a hint.

My MSI GS65 Stealth Thin 9SF is brand new (and a heck of a machine if you want my opinion).
The only bloatware was Norton, and I shot it in the head the first time it popped up.

I think it’s about time that McNeel re-did the interface within a single robust, modern framework.
Less jittery
With a dark side
and possibly with better looks so that one unfamiliar with the state of things would not think Rhino is a crummy old Grasshopper plugin.

@stevebaer I’m not aware of a command to list the loaded modules associated with the Rhino process.

@osuire the following python script will copy the list of DLLs that Rhino is using to the clipboard. Can you try running this on your computer and send me the results?

import System
import System.Windows.Forms as swf

sb = System.Text.StringBuilder()
p = System.Diagnostics.Process.GetCurrentProcess()
for module in p.Modules:

print 'Module list copied to clipboard'

Replied in PM

@osuire you have the nahimic osd installed on your computer. This may be the source of the problem. See @jeff’s post about this at

It looks like the user in that post fixed his problem by disabling the nahimic service

An audio driver is screwing up Rhino’s interface ?
Ha ! Ha ! Ha !

Jeff’s response:

There’s really nothing I can do about this… The DLL is getting injected into Rhino’s process space, and then performing an operation that eventually hangs (spins forever)… Since I don’t have access to that code, I can’t fix it. Unfortunately, unless there’s some kind of update for that driver/service, the only solution is to not have it running when starting/running Rhino… So yes, what you’ve done I would consider the “permanent fix”.

I can’t be sure, but it is showing up in your list of DLLs being used and we have had problems with it in the past.

My theory is (just that, a theory mind you) Nahimic is detecting Rhino as a “game” - because it has some 3D capability - and is trying to do something with it…


I say this because years back Logitech tried to “enhance” their mouse performance by automatically detecting games and using certain settings when a “game” software was being used. Rhino got detected as being a game, and the mouse driver turned off all the mouse acceleration (which is apparently something gamers don’t want/need) when you were in the Rhino window. You had to go into the driver panel and find the hidden box that said “don’t do that” to get it to stop.

1 Like

It would be nice to know if this makes a difference

My colleague has the exact same problem on his machine, and Nahimic is nowhere to be found.
It’s a shame my ASUS laptop died because I’m almost sure it didn’t have it neither.

Now maybe on his Alienware, there’s another plugin messing with Rhino, and same on my ASUS and also on the various desktops… so what’s the solution ?
Wage ware against the leading hardware brands and their plugins, or somehow re-do the Rhino interface so as to make it impervious to outside influence ?

Quick note here : this NEVER happened in Rhino V5, and the new interface looks and feels every bit as crappy as it did then.
So why not just revert to the old one which at least worked ?

Did you try disabling Nahimic on the laptop that has it installed? If so, did that make a difference?

We haven’t gotten to the point yet to understand the cause of the bug. Once we have established a cause we can figure out what action needs to be taken

Here is something else to try. Does the user text panel display on these computers?

This panel is also based on WPF but has completely different logic behind it than the annotation oriented panels. If this is also blank, then most likely something is interfering with WPF on these systems. If this is not blank, then there is a good chance that there is a bug in our annotation panel logic.