V7 Bug: Shaded with Rendering Material is Broken

Non-rendered, non-shadowed display modes like this very important for large projects.
It’s broken both on my laptop and desktop. I know it’s beta, just sayin’

Edit: I found that it will work with “Advanced GPU Lighting” enabled, but the behavior is different than V6.