Display mesh is way too off


#1

Hello,
I’m currently modelling a highway (units mm, it’s located about 1 km from the origin)

And the display mesh after simple boolean is totally off - do you please have any idea how to improve it? I wouldn’t mind, but it produces this geometry after export to sketchup and I’m afraid how it would look like later on in 3ds max.

Thanks

-Jonas


Disappearing surface fills & curves when trimming surface
(Pascal Golay) #2

Hi Jonas - the way out is to move the objects closer to the World origin.

-Pascal


#3

Hi Pascal, I moved it to the origin but to no avail. Would you care to look at it, please?
highway test.3dm (342.6 KB)

-Jonas


(Pascal Golay) #4

Hi Jonas - it looks like the default mesh settings do not work well for this object at this scale - I would set the mesh (DocumentProperties > Mesh page) to Custom and either reduce the Max Angle to 5 or so, or set a Max Distance Edge to Surface - maybe 10 mm might be a decent start. BTW, on Export you can Meshto taste first and export the mesh object.

-Pascal


#5

Thank you, Pascal,
That solved it. I’m still getting used to this duality of actual nurbs geometry and preview mesh geometry. So I suppose I will mesh manually before the export. Thanks!

-Jonas


(Menno Deij - van Rijswijk) #6

This may be helpful

https://wiki.mcneel.com/rhino/meshfaq
https://wiki.mcneel.com/rhino/meshfaqdetails