Display error (from 5.4 prefs import?)

mac
rhinoformac
rhinowip
viewport
preferences

#1

We made on a client an error by not updating to 5.5 and opening once - prior to installing v6 WIP.

Now it seems the display prefs are totally out of control — this is how an empty file looks:

We already deleted the prefs, that was no help.

Does anybody know where to delete / reset sth. to get a standard display setup?
Thanks!


Visual problem at Rhino for WIP viewport
#2

Hi msmr,

I suppose you should send your current systeminformation details too (command: systeminformation). The most problems come from old graphics card drivers. Is your graphic card driver up-to-date?

Cheers

Michael


#3

Thanks, @Michael_Meyer.

systeminfo says:

Rhino 6 SR12 2018-11-27 (Public Build, 6.12.18331.12056, Git hash:master @ 741b185a2224361744ebc400f77bcaacb77e22d0)
License type: Beta, build 2018-11-27
License details: Cloud Zoo.  In use by: xxxxxxxxx (xxxxxxxxx)
Expires on: 2019-01-11

Apple Intel 64-bit macOS Version 10.13.6 (Build 17G3025) (Physical RAM: 16Gb)
Mac Model Identifier: iMac12,2
Machine name: NAMEEE
Language: de-DE (MacOS default)

AMD Radeon HD 6970M OpenGL Engine (OpenGL ver:4.1 ATI-1.68.20)

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: On
  Redraw scene when viewports are exposed: On
  
  Anti-alias mode: 4x
  Mip Map Filtering: Linear
  Anisotropic Filtering Mode: Height
  
  Vendor Name: ATI Technologies Inc.
  Render version: 4.1
  Shading Language: 4.10
  Maximum Texture size: 16384 x 16384
  Z-Buffer depth: 24 bits
  Maximum Viewport size: 16384 x 16384
  Total Video Memory: 2 GB
  Graphics: AMD Radeon HD 6970M
  Displays: iMac (109dpi 1x)
  Screen size: 2560 x 1440

USB devices
  Apple Inc.: FaceTime HD Camera (Built-in)
  Apple Inc.: Bluetooth USB Host Controller
  Logitech: USB Laser Mouse
  Apple Computer, Inc.: IR Receiver
  Apple: Internal Memory Card Reader

Bluetooth devices
  Apple: Apple Wireless Keyboard
  Apple: Apple Wireless Trackpad

Third party kernel extensions
  None

Third party plugins
  None

Rhino plugins
  /Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp	"RhinoCycles"	6.12.18331.12056
  /Applications/RhinoWIP.app/Contents/PlugIns/NamedSnapshots.rhp	"Snapshots"	6.12.18331.1002
  /Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp	"Grasshopper"	6.12.18331.12056
  /Applications/RhinoWIP.app/Contents/PlugIns/PanelingTools.rhp	"PanelingTools"	6.12.18331.1002
  /Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp	"Commands"	6.12.18331.12056
  /Applications/RhinoWIP.app/Contents/Frameworks/RhMaterialEditor.framework	"Renderer Development Kit"	6.12.18331.1002
  /Applications/RhinoWIP.app/Contents/PlugIns/Alerter.rhp	"Alerter"	6.12.18331.1002
  /Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp	"RDK_EtoUI"	6.12.18331.12056
  /Applications/RhinoWIP.app/Contents/PlugIns/Displacement.rhp	"Displacement"	6.12.18331.1002
  /Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp	"IronPython"	5.1.2015.132
  /Applications/RhinoWIP.app/Contents/PlugIns/RhinoRender.rhp	"Rhino Render"	6.12.18331.1002
>

#4

The ATI HD 6970M is from 2011, this looks old to me. But the Apple experts here can tell more for sure.


#5

Who could that be?

@dan


(Dan Belcher) #6

Unfortunately, I don’t have this iMac around to test on to see if we can reproduce it. We have seen this sort of thing with older cards and the AMD drivers for on macOS are …disappointing. That said, we have seen some improvement to some drivers in Mojave. I would love to hear if you are still experiencing this in Mojave (10.14.1) or not.