Display crash (OpenGL)


#1

Hello,

I’m using Rhino 5 v32bit SR8. Here is my settings.

I use two plug-ins : Pointools4Rhino and VisualARQ. Pointools4Rhino needs OpenGL to work (displaying point clouds).

I work with 3 monitors, two are linked to my graphic card (NVIDIA GeForce GT 610), and the third one is linked to the motherboard. The CPU is an Intel Core i7-2600 @ 3.4GHz and there’s 16Go RAM.

All of this used to be pretty stable, but recently it turned to be really unstable and crash often. Actually, there is a display/opengl crash at first, while the software still works, then it makes Rhino totally crash. Before Rhino dies, the menus don’t show up when clicking on the bar, but I can open then by pressing Alt and the “F” for file menu, etc. But unfortunately, it’s impossible to save the document. During a period it was possible but now it says that there is an issue in reading or writing the file. We can save the file without any problem before the display crash so I don’t think it’s related to my file. I think the crash happens when the display is “regenerated”, when I switch a layer on, when I pan into a window, or when I select an object, etc.

If you have any idea to fix this, I’ll be glad to hear that.


(Willem Derks) #2

Hi Clement,

Is there anything you know changed recently?
Updated drivers; windows update; other software running in the background…
I have no solution, but more information I guess will be of use for those who might know.

-Willem


#3

Good question indeed. But unfortunately I’m not really about that. I could say if it started with Rhino SR8 or if it started with the few little updates windows made these last days. I guess it would have helped making a statement about this issue and find a solution, but I could not say what happened when it started to crash.

One thing that I didn’t mentionned yet, is the fact that the autosave feature doesn’t work anymore. When i type Autosave, it does work and create a file but it doesn’t work by itself. I believe this happened for about the same amount of time.


(Pascal Golay) #4

Hi Clement- As for Autosave not working, do you mean that you set the Autosave on, and set the time for autosaving and you never see an Autosave file created in the Autosave directory unless you explicitly use the command? Keep in mind that these Autosave files are deleted when Rhino successfully closes its file, so check this while the file is open.

-Pascal


#5

I had Autosave on, and a timer set to 5 min, and there was no autosaved file created unless I typed Autosave. Even when the file was open. I even thought that the autosaves made Rhino crash, so I switched it off

Actually, I haven’t got any display crash for about 4 hours this afternoon, so I just tried to reactivate the autosave to see if it worked as you said and it seems that it works again. Everything looks fine. But I fear that this is only temporary. And as soon as I get a crash, it won’t work anymore.

I hope that it stays this way, but if it doesn’t what can I do?

Thanks for trying to help me!


#6

As I expected, today I’m getting openGL crash and then Rhino crash again. Any ideas about this?


(John Brock) #7

Rhino’s Autosave feature can not work in this situation. The OpenGL driver is crashing. When Windows restarts it, Rhino is left running in the background with no display pipeline. Rhino isn’t crashing. Windows is making it blind.

I fear the problem we’ve been seeing on the Quadros for so long is now arriving on the GeForce cards.

I’m running a GF 750M with drivers that date from 9 August 2013 and I do not see this problem. My best recommendation is to try an earlier driver. I can’t be specific as to which one because we haven’t done ant testing.

Your only other option is to to into Rhino Options - View - OpenGL, and uncheck the option for using accelerated hardware modes. Then you’ll be using Windows OpenGL and not the Nvidia driver.


#8

Thanks for your reply. I understand and agree with your points. But when I said that Rhino was crashing, it does crash too. Whenever the display has crashed, I have the opportunity to save the file and then restart Rhino, but sometimes, when I try to save the file or do other things Rhino simply crashes. Anyway, I guess you’re right when you say it’s related to the driver.
I can’t afford to disable hardware mode as it is required for Pointools plug-in. So I will try the downgrade driver solution. Thanks for the idea.


(John Brock) #9

This might be work messing with:
Nvidia Support - OpenGL message “lost connection”

http://nvidia.custhelp.com/app/answers/detail/a_id/3007


#10

[quote=“John_Brock, post:9, topic:7919”]
This might be work messing with:
Nvidia Support - OpenGL message “lost connection”

http://nvidia.custhelp.com/app/answers/detail/a_id/3007[/quote]

It could definitely match with my problem, I will try to set the time-out limit higher that my graphic card have the time to regenerate the display. I hope it will work. I’ll send a message if I see that it works.

Thanks John!


#11

Sadly, it seems that it didn’t solve the problem, I set it to 8 then 16 sec, and I still lose the display. Then it is not possible to save anything. But what I found as a solution to avoid losing too much work, is that leaving Rhino alone can make him do a working autosave after the display crash. The trick is to copy or move this file somewhere else so that, it doesn’t disappear when you exit Rhino or try to save. But it’s still very annoying as I have to change sevral setting of Pointools plug-in when I restart Rhino. I lose 10-15min everytime it crashes, if I manage to make the autosave.

Is there any other ideas? Is it possible that it would be related to the plug-ins I use and not display drivers?


#12

The only way to know would be to use Rhino rather extensively without the plug-ins… If the crashes stop, then it’s a plug-in. Add them back one at a time until the crashes start, then you’ve found the culprit…

–Mitch


#13

You’re right. Unfortunately, I won’t be able to use Rhino without the plug-ins as they are part of my process in my work. But whenever I’ll be able to try that, I will do it and see if it still happens.
Thanks for the answer.


(John Brock) #14

By chance are you running Chrome?
One of the other techs ran into a very similar description and the solution was to turn off using hardware acceleration in Chrome’s Advanced settings.


#15

Yes, indeed, that is a quite smart question. I do use Chrome. And I will try to disable this settings. Thanks for trying to help!


(John Brock) #16

I use Chrome extensively and have not turned off the hardware acceleration setting.
I also am running an Nvidia GeForce GT 750M in a Windows 8.1 Dell All-In-One touch screen.
Since I have not had any of these issues, I have not updated my display drivers. I’m running driver version 9.18.13.2660 dated August 9, 2013.

I don’t know if that helps any, but there may be a useful nugget there somewhere.


#17

HI All,

as my setup is somewhat similar, i’ll post my experience with the latest drivers.

I run 3 screens (1280x1024,2560x11600,1200x1600portrait) on 2 quadro 4000 cards since about 3 years.
It was running pertty much fine most of the time, although the cards are not as fast in Rhino as they are expensive…

But in the recent past, since the last few driver versions, i experienced a LOT of crashes in rhino, especially with clipping planes involved.
That was also when running the older Quadro driver recommended on the wiki page.

I have now since about 2 weeks installed *332.76 and it is like a different world!!
not a single crash since then… even when pushing the same project files as before.

so I can very much recommend this driver, although i would not know the “equivalent” in Geforce.
But maybe there are similar improvements in the latest drivers for geforce too. worth a try

Btw. for those who happen to run more than one Nvidia card (not sure about ati in this regard):

if you shift+Rclick on a program icon (like rhino) you can choose on which card to render openGL.
that is why I use two cards, I can run Photoshop in GL on one and Rhino on the other… or two rhinos on one and two on the other. This has nothing to do with SLI, just two cards plugged in.

cheers,
Daniel


#18

I am not seeing the Nvidia driver 322.76 for my Quadro K4000 on Windows 8 / 64 bit. I am running the 332.76, but it is crashing way too much. Can anyone share the recommended / stable driver for the card I have?


(John Brock) #19

As far as we know, there are no stable drivers for Quadros under Windows 8 yet.


#20

I updated to the last drivers yesterday and my Quadro 6000 is crashing often. I get OpenGL errors for Rhino and some times for Photoshop. At the web I found that the problem could be the Nvidia power management. No solution yet.