Rhino Crashes - Drivers up to date

crash
creators
diagnose
nvidia

#1

Hello all, I’m sorry to bother you, but I was wondering if somebody might be able to shed some light on the situation.

I can’t seem to open Rhino with accelerated graphics enabled. I wouldn’t be too bothered frankly but I am having to work on complex models at the moment as we are approaching end of year submissions and I finally understand the importance of hardware acceleration.
I find it strange that after 2 years of using Rhino it suddenly starts misbehaving. While I am suspicious of the Win10 Creators update being the culprit I have done some cleaning up of my PC today that I can’t be sure if it is related. As such I am wondering if anybody else is having issues since the creators update which would shed some light on the situation?

Failing that - to improve general performance of my computer I have done the following:
Uninstalled a number of redundant software which may have been tied to Rhino and I don’t know if it deleted some files necessary for Rhino:
-V-Ray 2.0 Trial

  • Blender
  • Keyshot Trial
  • Energyplus v 8.4
  • Radiance
  • Daysim

I updated the graphics card drivers to the latest available through GeForce Experience.

All that was earlier today, about an hour and a half ago I tried to open rhino to get back to work and have been stuck scouring the internet for solutions since, is there any form of diagnostics I can run on Rhino to determine what the issue is?

And is it possible to just reinstall Rhino 5 again, I am concerned given my luck that this will screw up the functionality of the other plugins I have installed such as VisualArq, Weaverbird and Grasshopper?

Any help would be highly, highly appreciated in this as frankly this is the worst possible time of the year to find myself with an unusable version of Rhino.

Thank you all,

Sash.

PS. In case it is helpful my rig consists of the following:

Processor (CPU) – Intel® Core™i7 Quad Core Mobile Processor i7-4810MQ (2.80GHz) 6MB
Memory (RAM) – 16GB KINGSTON HYPER-X IMPACT 1600MHz SODIMM DDR3 (2 x 8GB)
Graphics Card – NVIDIA® GeForce® GTX 850M - 2.0GB DDR3 Video RAM - DirectX®
1st Hard Disk – 2TB SERIAL ATA II 2.5" HARD DRIVE WITH 32MB CACHE (
M.2 SSD Drive – 240GB INTEL® 530 mSATA 6Gb/s SSD (upto 540MB/sR | 480MB/sW)


#2

My first thought was “reinstall Rhino!”, but maybe wait until someone smarter chimes in. :smiley:


#3

Yeah reinstalling Rhino has had no effect whatsoever sadly, it still crashes with seconds. I can’t seem to run Rhino WIP either anymore it seems


(Pascal Golay) #4

Hi Sash - so, things worked, with acceleration, up until the Windows Creator update, is that correct? And it works now, but not with acceleration on?

-Pascal


#5

Yes exactly, I did uninstall the things I mentioned in between the creators update and starting up Rhino last night as well though, though it seems unlikely that they were involved because now that I think about it, I couldn’t start it as it kept freezing while trying to load V-Ray for Rhino, so I thought V-ray might have been causing an issue if the trial had expired, but I guess it was already part of a larger issue.

Sash


(Pascal Golay) #6

Hi Sash - Creators has caused a few problems but this is the first I’m hearing of this crash. My tentative hunch is that, maybe, drivers have not caught up, but I don’t really know that.

Scott tells me the registry gets ‘adjusted’ by Creators so it is possible that disabled plug-ins are in fact loading… make sure (for now) non-essential 3rd party plug-ins are disabled.

One other thing is that Creators seems to handle scaling for dpi in a different way- we’re wrestling with that now as well - but it may be, just a shot in the dark, that a different setting in the application ‘Compatibiity’ might make a difference:

-Pascal


#7

Hi Pascal - thank you for looking into this, it’s a massive reassurance.

I have all non-native plug-ins disabled already, I tried to have all 3 of the DPI scaling options but none of them showed any difference, each time Rhino crashes within seconds if hardware acceleration is on.

You mention the registry, I don’t know if this is relevant but I have CCleaner which has a registry cleaner as part of it’s functionality which I run about once a month or so, would it be possible that this would have wiped something important this time around because of the update? I could restore the registry values and try again?

Also I reported this issue and I don’t know whether the data they sent me might shed some light?

Executable="64-bit Rhino 5 on 64-bit Windows 8"
Uid="08264a3f-086c-44b5-985f-d2485e6c8603"
BuildConfig="RELEASE"
BuildVersion="2016-09-13"
CompileDate="Sep 13 2016 22:50:35"
SDKVersion="201103035.201609135"
OpenNURBSVersion="201609135"
WindowsVersion="Win64 Platform 2, version 6.2 build 9200 sp 0.0, suite 768, product type 1, processor x64"
svnRevision="139794"
PrimaryDisplayDeviceId="PCI\VEN_8086&DEV_0416&SUBSYS_65011558&REV_06"
PrimaryDisplayDeviceString="Intel® HD Graphics 4600"
PrimaryDisplayDeviceDriverVersion="20.19.15.4531"
PrimaryDisplayDeviceDriverDate=“9-29-2016"”

-Sash


(Pascal Golay) #8

Hi Sash - can you please open Rhino’s Options > View > OpenGL and send a screen grab of that page?

thanks.

-Pascal


#9

Hi Pascal,

Yes, without hardware acceleration I get the following:

With Hardware acceleration it changes to, the second I hit okay, it crashes:

Sash


(Pascal Golay) #10

Hmm - Driver Version and Date ‘NA’… I guess I’d look at the drivers still - it looks like there may be a version for Creators available, just had a quick look round-

-Pascal


#11

Hello,

Yes I have checked it numerous times and I have the 381.65 driver, yet it doesn’t seem like my Rhino is recognising the fact that it is installed

-Sash


(Pascal Golay) #12

Yes… let me see what I can find out.

-Pascal


#14

Thank you very much Pascal


(Steve Baer) #15

It actually does look like the driver is being recognized since 381.65 is being listed in the OpenGL version section in Rhino. Rhino just requests informative text from the driver and it is relatively common that this text isn’t returned which is when you see NA.


(Pascal Golay) #17

Hi Steve, Jeff, ok- thanks… any ideas at all about the crashing then?

-Pascal


(Jeff Lasor) #18

Have him capture the dump file and post it here…I’ll be glad to take a look at it.


(Pascal Golay) #19

Hi Sash - I should have asked this before - are you seeing he normal McNeel Crash report system kicking in? If so please send in the crash report. If not and there is a Crash Dump file on the desktop, please zip and send that - you may be able to attach it here, and if not, please send via https://www.rhino3d.com/upload to my attention , I’ll pass it along.

thanks,

-Pascal


(Jeff Lasor) #20

My guess though is that this is crashing at such a low level in the driver, that we won’t be able to isolate why. It sounds like something may have messed up the side-by-side associations for who know which libs.

The one thing I would do is:

  1. Perform a complete “Clean” install of the video drivers
  2. This requires selecting “Custom” install on one of the first NVidia install screens. Checkbox “[ ] Clean”…check it!
  3. This will completely delete all NVidia driver files, may require a reboot…and then continue to install the drivers.
  4. When the whole process is completed…reboot the machine again.

-J


#21

Hello all,

Yes the crash reporter boots up as it should the second Rhino crashes, I didn’t want to clog your system with my files however though so I only sent one file yesterday, and theinformation I posted above came from Rhino’s automated reply service.

I will upload the file to you now. Here is a GDrive link just in case:
https://drive.google.com/open?id=0By9UI8u74lOuQnJWN0M1LWVFeWs

After Pascal’s thought that it might be driver related, I did go back into nVidia to reinstall the drivers and I had used “clean install” as it said that it would remove any previous user profiles (not that I remember making any) anyway I have restarted since but the problem persists.

I hope this helps, thank you all again.

Sash


(Jeff Lasor) #22

Unfortunately the crash dump doesn’t tell me anything…it doesn’t even show it crashing in the NVidia driver…is in a low level system library.