Disappearing decal

Hello everyone,

I’m trying to export renderings in PNG with background transparency in Rhino.
I’ve put decals on some objects, which appear perfectly on all scenarios but disappear as soon as I go to the pop-up window Rhino Render on CPU to prepare the export. The PNG file does not show the decal neither.

Here is a screenshot directly from rhino’s normal view :
Screenshot 2023-06-21 at 16.39.21

I’ve seen some topics talking about this throughout the years but haven’t found an answer in them.
This is probably something really easy, sorry ! I’m quite new to Rhino renderings, used to switching to Keyshot at my old workplace!

Hi @Charlie_L ,

What version of Rhino for Mac are you using and can you upload a small sample 3dm file that shows this issue?

Hi Brian, thank you for your reply and your help.

As much as I would’ve loved to share my file openly to help out the community, but I’m afraid my file contains my company’s next marketable product. I’m not aloud to share its content.

In order to share a sample, I tried replicating the problem on a random file, and… it all seems to work fine! I’m guessing it has something to do with my object, parameters or something?

So I went head and tried using the same material parameters, decal properties, rendering settings, the original file still results on the decal disappearing.

I then modified my original file to delete all compromising content but still have the important elements to recreate the problem I’m having. Here it is : SwissTransfer.com - Envoi sécurisé et gratuit de gros fichiers

Thank you for your help !


Hi @Charlie_L ,

Thanks for the file, it is missing the texture(s) used as a decal however. Can you provide these?..
If “Save Textures” is checked when using SaveAs or when initially saving the 3dm, they will be embedded.

Hello again :slight_smile:

Here it is SwissTransfer.com - Envoi sécurisé et gratuit de gros fichiers
Let me know if this works out for you.

Thanks again,


I used another image for a decal and it works here in Rhino 7 when rendering and saving the render to png. My guess is that you have two decals on the object and one may not have an alpha (lexan image) so it is blocking the other with all white. You also have a Plastic material assigned that at one time was another material type and had an image texture in it. Replace your material with a new one and delete the first decal on the object as a test.

Hello again,

So I managed to make it work!
I tried many things.
I erased all materials, textures, decals…and set them up again but that didn’t work out.
So put a decal on other solids, the same image i’m trying to use as well as other random ones. And it worked on the other objects but still not the surface I’m interested in.
Finally, I rebuilt the piece from scratch and … it worked. I’m guessing I did something, somewhere…

Thank you for all your help and guiding me through this. I’ve been fighting it for a week :sweat_smile:


@Charlie_L Yes, there is something with that polysrf that causes this issue just on Rhino 7 for Mac. A fast workaround I found is to use ExtractRenderMesh on the polysrf and then assign the decal again. That mesh will render as you expected. I was not able to reproduce this issue in Rhino 7 for Windows and it also doesn’t happen in the Rhino 8 WIP on Mac so that’s good. My hunch was that this Brep (polysrf) may have had a display mode override or per face colors from a Step import but that didn’t seem to be the case. I hope the ExtractRenderMesh workflow helps if needed.

Hello Brian,

As I remade my object from scratch I won’t be able to test those solutions. But it is definitely linked to something in that shape!

I’ll keep them in mind all those solutions for next time if it reoccurs.
Thanks again for your help.


1 Like