Decals disappear

Whenever I save my file, some (not all) decals disappear. They aren’t deleted from the part, just become invisible. If I run _ViewCaptureToFile, they re-appear.

I take that back - they all become invisible.

Hey Pete, good to see you around here again!

  • Are you running flamingo by chance? (render>current renderer) And if so, are you using flamingo decals, or the rhino render decals (there are two decal systems…don’t get me started…)

Is this a file from an older version of rhino, or is it created and decaled in v7?

I have seen that here as well on and off with v7 wip releases…
please run the systeminfo command inside rhino and send us the result-

Not using Flamingo, just Rhino. This is happening in rendered viewports, fwiw. These are new files I’ve been creating in V7 with some parts imported from v6 (or from clients in some cases.) I think it doesn’t happen until there are a few decals in a file, but once it starts it happens every time I save.

Rhino 7 SR0 2020-4-7 (Public Build, 7.0.20098.14255, Git hash:master @ 722815a2cc6d608c61fa901937505fe0bb80df0f)
License type: Commercial, build 2020-04-07
License details: Cloud Zoo
Expires on: 2020-05-22

Windows 7 SP1 (Physical RAM: 16Gb)

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro K3100M (NVidia) Memory: 4GB, Driver date: 11-10-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 426.32

Secondary graphics devices.
Intel® HD Graphics 4600 (Intel) Memory: 2GB, Driver date: 5-17-2013 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-10-2019
Driver Version: 25.21.14.2632
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” 7.0.20098.14255
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino WIP\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino WIP\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.0.20098.14255
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.0.20098.14255
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.0.20098.14255
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.0.20098.14255
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”

windows 7 is technically hot supported for rhino v7- :frowning:
your intel hd card has a 7 year old driver, I’d try and update that just as a matter of maintenance,
and your quadro is a year out of date, I’d update that as well…it may help, and at the least you’ll be using the latest drivers for our newer display stuff.

BUT…that said…decals should not disappear in any circumstance.
any chance you could upload a file we could test and it’s associated image files?

Uh, come to think of it, this happens in V6, too. Right now I have a file that I run in v6 only. It has a half-dozen decals & a few textures. And I have a file in V7 with a half-dozen decals & a few textures. Happens in both files whenever I save my file.

I just tried to update my Quadro driver today & it failed. Probably need a new computer.

I can’t send a file b/c of client confidentiality. I’ll try to create something new.

cool, we’ll dig into it once it lands.

and yes., you need a new computer… :slight_smile:

fwiw I am using a titan computing machine and it’s been great, and 1/2 the price of the boxx I was using (and loved) before.

Oh good - I’ll ask you more about Titan once I’m ready to do that. Soon!

Here’s a file.

I notice that, after I save & the decals disappear, if I change one of my other viewports to rendered then go to perspective view & ‘change’ it to rendered (even though it was already rendered), then the images re-appear. At least in this example.1 004.3dm (418.2 KB)

Apparently I’m wrong about needing multiple images to demo the problem. That file just has one decal with one image on it.

Here’s a video of what I’m seeing.

1 Like

yep! seeing the same thing here- bug!
writing it up now-

I love bugs that become dead bugs.

Thanks!

Check for updates next wednesday, the new sr should be out then hopefully the fix makes the cut-

Best to you and the fam!

Best to you & your family too!

Guys - I’ve looked into this. It’s not easy to fix - the reason this happens the way it does is very complicated.

The way to fix it is, after you save, close Rhino and reopen the file from the location you just saved it to.

I will try to sort this out as soon as possible, but since there is a workaround I can’t prioritize it higher at the moment.

https://mcneel.myjetbrains.com/youtrack/issue/RH-57850

Would it make sense that another work-around would be to switch all views to wireframe before saving, then just switching back to rendered views? I only did a quick test, but that seemed to work.

thanks andy-

Peter

It wouldn’t work. I’m talking about a workaround you can use with the current product. Im still thinking about how to fix this.

Andy