Lines disapear


#1

HI! Having problems with disappearing lines. When I select these lines, they are there but when unselected - cant see them?


#2

The usual first question in cases like this is:

Do you have the latest drivers for your graphics card?


#3

Thanks for answer! Seems yes I have latest drivers.


(Pascal Golay) #4

Hi Vahur- can you post the file or send it to tech@mcneel.com?

thanks,

-Pascal


#5

That doesn’t have anything to do with graphics drivers.
Make 2d is notouriously unreliable with curved outlines in perspective views.
It is not a problem of Rhino not showing said lines - they simply arn’t there because of Make2d sketchy behaviour.

Norbert


(Wim Dekeyser) #6

well, obviously the curves have been created as selecting them shows them in yellow in the picture that was posted. It is hard to tell from the picture and a file would help. If I were to guess from the picture, I would say that the tangent curves layer has the same color as the background…


#7

I don’t think you are correct, since the lines are there when they are selected.


(Ioannis Zonitsas (Visual-Dream)) #8

Hi Vahur, I have several questions: which graphics card are you using (brand, type)? How did you create the perspective faulty wireframe? What object description / typology do you get in the properties when you click the yellow object? Thanks!


#9

This looks similar to the problem I posted some time back.
In my case it’s a random problem when the curves are on the construction plane - they either simply don’t show up (unless selected) or show up partly like the above.
I think it is to do with graphics card / drivers, which in my case (ati on toshiba laptop) I cant update…

Cheers
rabbit


#10

You are, quite obviously, right.
Norbert


#11

Hi rabbit, if you temporarily disable “Use accelerated hardware modes” from your OpenGL settings:

_Options >>> Rhino Options / View / OpenGL

you might by able to verify if it`s related to your graphics driver.

c.


#12

Thanks a lot everybody!!!
Problem seems to be related with graphic card. Anyway I decided to buy a new computer so I hope I can fix this problem as well.
Thanks one more time!


#13

Is your Ground Plane turned on? That will do it if your model is laying right on it.

I also run into something similar that’s related to the camera. If I select the model and zoom-selected, it solves the problem.

Did I mention the Ground Plane?


#14

Clement / James

Thanks for your suggestions.
I don’t have the ground plane on.

Next time it happens I’ll try turning off the hardware acceleration and also zoom select the selected model.

Thanks for your suggestions.

Cheers
rabbit


#15

Well, just happened again - zoom select fixes it sometimes, and if not, then zoom extents gets it - ie when i come back into whatever it was I was working on everything is good…
So it would seem to be something to do with the camera, and maybe the graphic card is not the culprit.

cheers
rabbit


#16

Try “TestZBiasFactor” and adjust until you get the result you are looking for. I found this disappearing line issue on one of my computers I had problems (previously adjusted this way) setting it back to "Default " corrected the problem.


(Pascal Golay) #17

Hi Tony- when this happens, and there is no selection, check the Properties panel for the camera and target coordinates - are they reasonable for that view?

-Pascal


#18

Ok - this will be a long running post, since it happens only intermittently…
Also, it only happens with curves that have been projected to the cplane in an ortho view…

Thanks
rabbit


(Pascal Golay) #19

Hi Tony - do you have the transparentt plane showing for CPlanes? Grasping at straws again, but that setting, per display mode, makes a mesh face that gets shaded/ghosted on the CPlane and I’m just wondering if there is some confusion there.

-Pascal


#20

Good call Pascal, but no…I didn’t even know that option existed!

It would be good if there was a command the user could run, which would take a snapshot of all the settings and everything pertaining to the current file and time, zip it and send it through to you guys…

Cheers
rabbit