Dimensions funked up?

I was in the middle of production this week and noticed there’s something wrong with dimensions. It’s not possible for me to change the linear resolution or the model space scale. I don’t think this is intended. Or is it? Those are the two only things I tested and needed and didn’t work. I had to go back to Rhino 5 to solve it.

Warning: Sound of machine running in background. Turn off volume

Running 6.10.18311.20531

Another video. You can see I also cannot delete the dimension.

Systeminfo:
Rhino 6 SR10 2018-11-7 (Rhino 6, 6.10.18311.20531, Git hash:master @ 0f9089a0035dcc6955732d57071445ecc29390f0)
Licence type: Commercial, build 2018-11-07
License details: Cloud Zoo. In use by: siemen ()

Windows 7 SP1 (Physical RAM: 16Gb)
Machine name: SIEMENC-PC

Quadro M2000M/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 411.95)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-8-2018
Driver Version: 24.21.14.1195
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Hello - That works here in my quick test… can you try with a brand new file and just add a dimension and try to modify it?

thanks,

-Pascal

That’s what I did in my last video.

Edit: Also note the flashing of the window when I open “Lengths units”. I noticed this a lot of versions before.

OK, thanks - I just installed 6.10 and that works as expected here as well. I’m not sure what to suggest - Does this fail in any dimstyle? What if you open the attached file - still wrong?

DimResolution_PG.3dm (27.2 KB)

-Pascal

No. But a dimension on its own isn’t a problem. The dimension needs to be linked to a curve like the video shows.

Try this file:
181123 DimResolution_PG.3dm (29.7 KB)

Thanks, that works here in 6.10… OK, I think I see - my bet of the moment is you have History locking on (‘Lock children’ checked in the History pane context menu) is that correct?

-Pascal

YES! That’s it. So obvious now you mention it but I had no clue what was going on. Would it make sense to get some kind of notification in the command bar like you get when you try to move objects with history?
“Unable to transform 1 history locked object.”

I think this sort of edit, like say display color, should be included in modifications that are immune from History locking - locking should only affect edits that would break history, which this does not. I’ll see if we can tune it up - thanks for pointing this out.

https://mcneel.myjetbrains.com/youtrack/issue/RH-49644

-Pascal

Yes, that makes sense.

What about this, do you see this in your rhino? It happens at around 00:38 in my last video.

Hello - I do not see that flashing, no - if the panel as a whole needs to scroll to bring an expanded section into view, there is some redrawing but not like what you show, so far at least.

-Pascal

Right. I get it whenever I try to expand any of those optional menu’s from that window. Wanted to point it out before but was always too lazy to make a video and topic about it.

Here you go. A video showing me going through all the menu’s. Takes 45 seconds to expand and minimize all options.