Dimension text getting blocked out

I know this was mentioned in a report a few builds back (which I searched for but can’t find in the similar to or via search).

Just had a crash, (which i filed a report and project file on). Relaunched, continued working, and after pasting come groups copied from a library file I went back and copied the dimension objects and pasted those into the other file as well.

After doing so, the dimension text is getting grayed out.

I’m on a 512MB VRAM limited GT 120 card (have a pair of GTX 970’s also installed but no monitors hooked up as they’re currently rendering). Don’t know if that’s a contributing factor.

Software information

Software versions
Rhinoceros version: 5.0 WIP (5A808w)
IronPython version: 5.1.2015.131
Language: en (MacOS default)
OS X version: Version 10.10.2 (Build 14C1514)


Third party kernel extensions
com.rim.driver.BlackBerryUSBDriverInt (0.0.68)
com.BT.kext.bpkkext2 (1.0.0)
com.nvidia.web.NVDAResmanTeslaWeb (10.0.3)
com.nvidia.web.NVDANV50HalTeslaWeb (10.0.3)
com.nvidia.web.NVDAResmanWeb (10.0.3)
com.nvidia.web.NVDAGM100HalWeb (10.0.3)
com.nvidia.web.GeForceWeb (10.0.3)
com.nvidia.web.GeForceTeslaWeb (10.0.3)
tc.tctechnologies.driver.PaeFireStudio (4.0.0 14255)
com.Cycling74.driver.Soundflower (1.6.5)
com.kensington.trackballworks.driver (1.2.0)
com.nvidia.CUDA (1.1.0)

Hardware information

Computer hardware
Hardware model: MacPro5,1
Processor: Intel Xeon CPU X5690 @ 3.47GHz
Memory: 24 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 120 512 MB
Memory: 512 MB
Screen size: 1920 x 1200, 1920 x 1200
Displays: DELL 2405FPW (94dpi 1x), DELL 2405FPW (94dpi 1x)

USB devices
Kensington: Kensington Slimblade Trackball
Apple, Inc: Apple Keyboard
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-10.3.1 343.02.02f04
Render version: 2.1
Shading language: 1.20
Maximum texture size: 8192 x 8192
Z-buffer depth: 24 bits
Maximum viewport size: 8192 x 8192

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None

As a followup, went into file setting to change the dimensions precision to 1.0000, and after doing so the dimensions did NOT update to show the change and the text bounding boxes are still gray.

Thanks for all the info on this. So far, I’m unable to reproduce it for a bug report. Is there a file you can provide? I’m wondering if the number of dimensions in the file, the font used or the number format has any bearing on reproducing it. I’ve tried copying dimensions between files too.

I suspect this is going to be fixed in the next WIP (tomorrow, if all goes well). @stevebaer fixed some seemly related issues and I wonder if it won’t fix this.

Still happening here, this was a new file from this morning.

Thanks for checking. @stevebaer, looks like there’s more investigating to do on dimension text.

@rhinorudi can you send me a simple file displaying this behavior? I have a lot of trouble repeating this and the file that I did get that repeated the behavior I fixed. There must be another corner case that I am missing.


I’ve had intermittent problems with dimension text… i’m wondering if it’s memory-based, as it seems to spontaneously happen when files have been open for a while. Closing and re-opening files or re-launching Rhino often fixes it.

I don’t think it is memory-based. Pretty sure there is an OpenGL state that I’m not accounting for when drawing text that gets set under certain conditions. The hard thing is figuring out exactly what those conditions are.

Intermittent problems are the WORST, aren’t they? :smile:

@stevebaer if i reopen the file it is fine. This is the first time it has happened with new build. I have some jobs to do tomorrow starting from new files. If it shows I will save and close and send that file.