Dimension style not printing as displayed

I have a project in which dimensions are printing with the text overlapping the dimension line rather than with the desired offset, which is set in the style setting and displaying correctly in both normal and PrintDisplay. I am using yesterday’s update.

This is a dimension style that requires a 150x scale factor in modelspace, and scaling checked for both layout and model spaces. The windows are 1/4 scale. The dim style has been used succesfully in 1/4" = 1’-0" windows in another project, and - as mentioned above - displays correctly in the project which prints incorrectly.

Can you send me an example model? Most of the time the dimension itself has a property override on it so it does not follow the style defaults. Does a newly created dimension act the same way?

Thanks for your quick response. I have just uploaded the project and an image as soon as I came out of a meeting. I think your upload system defaulted to identify my address as the sender though - I’m at an office without your email address. If I need it please advise.

Hi @djhg - we just chatted on the Rhino website. I think your issue with the upload website is solved, right?

Thanks, V.
It is with Pascal, but I don’t have an address with me to input for Scott. I used the link you gave me and though I mentioned Scott’s name in the message, the “to” input field contained either whatever is default, or (as it is opening now) my email address.

@djhg - That’s fine… it should send it to tech@mcneel.com. Add a link to the related discourse post, you can also ATT the McNeel techie you’ve been in touch with. We will dispatch it to the right person or simply take care of it ;-).

Okay. Thanks Vanessa. Scott may wonder how urgent this really is (I emailed him overnight about this) because he responded 4hrs ago while I was in a meeting and I’m just getting back to him now. Still hoping to sort it out asap.

I really need a solution.
But it turns out that with Tibidabo and Va disabled the issue corrects itself. Maybe Enric and company can create a work-around.

@enric, can you see if you can repeat this issue with VA installed?

Hi @djhg,

This issue is already fixed in VisualARQ 2.3.

Moreover, the issue is related also to the other problem of VisualARQ printing in “Hidden” mode the “Technical” details. If you change the “Technical” detail to “Wireframe”, the issue shouldn’t happen in VisualARQ 2.2.

In VisualARQ 2.3, this will be printed correctly even if there are details using the “Hidden” display mode, as text offset issues have been solved.



The dimensions in the detail at the bottom left are still corrupt.

I’ve tried to print again, just opened the file, and press print using “CutePDF” printer, and all seems correct:

Dims printing offset.pdf (591.6 KB)

I can’t remember what I did last time, but there are no changes in the print code since last post.


Hi, I think I have a similar issue. All the text I have added in the layout (apart from any that are part of a block) appear about 10% bigger in the print preview and in the actual print. There is no text in model space, just the layout and I have both text scaling options turned off in Settings > Annotation Syles.

Any text which is in a block prints out as intended. Is there another text scale setting somewhere or is this a bug?

Correction: I tried blocking the entire layout apart from the detail views and all the text was still scaled by about 10%.

Please post a 3dm file that shows the problem. Are you running VisualARQ?
Also, run the Rhino SystemInfo and post the result here.