Dimension problems - no vertical dimension

Hm, okay, its weird. it works sometimes. From what I can work out:

Enable OneView. Move to say a view where it says “front” in the top right. Then click on linear dimension. Nothing happens and its not letting you create a linear dimension in Z. But, if you then right-click it will repeat the dimension command and now the cplane will automatically switch to a front view one and you can draw a dimension in Z.

But why only when I right-click and not when I just click on the button for linear dimension?

the cplane determines the location and orientation of the dim-

osnaps determine where in relation to the cplane the dim gets placed.

I run with planar mode on as well-

I recorded a small video to show what I mean. It should work in theory, but I don’t know why it is not switching the CPlane when I hit the button, but it does if I use right-click to repeat the command!?

@wim I just noticed that using OneView was your suggestion all along and I didn’t really see that back then. Can you confirm that OneView is working as intended in the video? It seems like a bug to me that the CPlane doesn’t change as soon as I launch any command, but only when I right-click and repeat the previous command?

Also it doesn’t set the CPlane back to top once I finished the command, even though ReturnCPlaneToTop is set to Yes !?

you may need to roll your view just a bit farther to get the cplane to change 1st, then run the dim command- it does work as expected here.

I’m guessing you are using a space mouse by the way your screen moves? Not sure if that has any effect on your results. I’m using a standard mouse here.

We have RH-66326 New DIM Align Options logged as a feature request for a Rhino.

This may eventually influence how other dimension like Leader, Radius, Diameter, Angular behave. Once we have DIM working, we will consider the other as well.

Oneview seems to be a nice work around. Thanks, @theoutside.
When there is something in the WIP ready to test, this thread will be notified.

Sincerely,
Mary Ann Fugier

@theoutside That is correct. Did a little test and it appears that OneView only automatically updates the Cplane when holding the right mouse button to pan. If you use a SpaceMouse OneView does not update the CPlane. I think OneView should either get an option to only work on right mouse button or rather it should not be set to only respond on right mouse down, as using a 3D mouse is at least one way of navigating without a mouse button being pressed. But I dont understand why it would need to be tied to a mouse button being pressed anyways. The point of OneView is that it updates on the fly, so surely it should not matter what I use to navigate the viewport.

@mary could you maybe add this as a ticket as well? Otherwise OneView is useless to us, even though it totally makes sense.

Just came across the system requirements for Rhino and noticed that the SpaceNavigator and SpaceMouse specifically get mentioned as “optional” in the requirements (which kind of doesn’t make sense, but okay).

Therefore if it is even listed there, I think that OneView should actually support the devices listed there.

Once you start with a SpaceMouse, you never want to go back and it becomes second nature. Please, somebody at McNeel fix OneView!