Dimension Arrow and size problem after importing STP?


#1

First time this happenned,

Tried repeating, but didn’t happen…
Havne’t touched arrowhead type at all so not sure why it changed.

<All became this huge size, even from initial dimension arrow, and changed to smaller through double click>
Now just changed the size and arrow from properties.

Steps:
Imported STP file from client, redrew some lines and took dimensions.


(Wim Dekeyser) #2

Hi Toshiaki,

Just to be clear, you were not able to reproduce the issue by following these steps?
From the looks of it, you somehow got to use one of the other dim styles for that one dimension but I don’t know why that would have happened.


#3

@wim

Tried many things and finally figured it out!
Seems I accidentally “opened” the STP file for the first object instead of “import”.

This seemed to get the setting from whatever the program client uses.
(If this is as specified for rhino v6 then there’s no issues/ problem solved.)


(Wim Dekeyser) #4

Thanks for looking into that some more!

I guess @lowell can tell us more about this, but I assume that unless the STEP file contains annotations itself, Rhino just has to create a default style on its own. At this point, pretty much any style will be “wrong”.


#5

Yes, when “Opening” a STEP (or DWG or some of the other non-native formats) Rhino tries to pull whatever document settings it can read from those files and use them. Using “Import” will import the geometry, but use the existing Rhino document settings. As Wim said, I don’t know if the STEP format actually defines dimension styles (I doubt it) or if it does if Rhino can read/reproduce them…


#6

@wim @Helvetosaur
Thank you for the feedback.

I can’t upload or send file due to nondisclosure agreement,
(if it’s more urgent issue, I’d ask client, but as the topic is minor…)

The company uses Solidworks in general, since it’s design surface maybe it was created with different software.
At least I know for sure it’s a step file.