Difference of line's width doesn't reflect print display nor PDF

Hello, I’m a beginner of Rhino6 for Mac (and English).

I tried to draw several types of lines. I created some layers and set up width of the lines (such as 0.3mm, 0.15mm, 0.1mm etc…)
However, I can’t distinguish them on the screen (print display mode) nor PDF file (I exported from Rhino)
All lines seem to have the same width.

As you can see from my screenshots, I also set different colors for every layer, and I can see the difference of line’s color on the screen (not print display mode), so I guess I could divide layers correctly.

I’ll attach some screenshots, so please check them and give some advice.


When I created PDF file, I also found that all letters have gone. I appreciate it if you also give me some help for this problem.

Thank you

There is an option in Print Setup under Destination Output Color there you can select Display Color and Print Color option.

And your letters are missing for that you can upload your file so that anyone can check whether they can reproduce the same issue your facing.


Hi, thank you for your reply!

I checked about the color and maybe I was able to understand about the setting of the color.

My main problem is that 0.3mm line and 0.1mm line look the same. If you can, could you check the 3dm file I attach below? Maybe that will help solving the problems of missing words.

Thank you for your kindness. (I’m surprised to get help from BVR again in such a short time)

早く作図する課題.3dm (4.1 MB)

ha ha this shows how I just loafed around here in Discourse. Jokes apart yeah even i faced problem with your Chinese text in PDF output. Once after exploding text i can see it in print PDF. Remaining all related to color, line-weight is working fine and perfect. For PDF issue i request @pascal to look over this.


screenshot attached with Chinese text after exploding.

PrintDisplay turned on.
Here’s a screenshot and a sample PDF with printed line widths.

Print Width.pdf (147.1 KB)

@John_Brock As i said above width is working fine and perfect. But did you tried with his file which contains Chinese text to PDF.

I’ll try with his file.

Really ? :worried:
I really feel sad because of your comment. As a rhino user and active member here in Discourse. I get a response like this from McNeel staff. @John_Brock these kind of comments motivates me not to be here.

I found some of the curves had widths assigned to them.
I changed them to all have their print width set By Layer.

Then I increased the print width of a couple layers to be big enough to see in a print preview.
This seems to be working correctly as far as I can tell:

Still you’re not into the text part. I don’t know why.

They show in this PDF I just made:
Untitled.pdf (276.0 KB)
Here’s another screenshot:

I hope it helps @kazuyuki.hayashide

My guess is if these details aren’t enough to figure it out, he should contact his regional tech support office.
I don’t think there is a general problem with Rhino.
I do know there is a lot of confusion around PrintDisplay.
A printer has much higher print resolution than a monitor. Print Preview is even worse as there just aren’t enough pixels to see the effect of with on the screen. Print Widths are in mm.

The font thing is a different issue so that makes it even more confusing.
You can only do so much in the discussion forum.

Sorry, I’m going as fast as I can. This is just one of the support realted “fire hoses” I’m standing in front of every day.
I’m sorry if I offended you. That was no my intent. I was trying to explain that I did not take the time to read the entire message thread.

Thank you for your hard work. Since I felt asleep around 8 hours ago, so I couldn’t reply to you as the discussion proceeded. I’m sorry.

Hearing your advice, I tried Explode command and find that letters appeared in the PDF. I think that’s a problem related to Japanese letter, so your idea works well as a alternative.

Thanks again for your help, and I’m looking forward to seeing you here next time :slight_smile:

Thank you for your help.

I guess these problems (especially width) might be related to the setting of resolution when I exported as a PDF (I tried to change it, and found that things went better than before), but anyway, the problem of missing letters might have been caused because of Japanese, so I’ll ask Japanese office and my professor for more advice.

I appreciate your kindness.

Applicraft is our Japan based support affiliate

AppliCraft Co. Ltd.
Yamano Yoyogi Bld. 4F
1-13-8 Yoyogi
Shibuya-ku, Tokyo 151-0053 JAPAN

Ph: +81-3-6825-8431
Fx: +81-3-6825-8432