Delete does not work - SOLVED


#1

Hello!
Test-driving Rhino 6 WIP, and noticed that the Delete command is simply not working! Neither by pressing DEL, nor by entering the command.
I’m not on a locked layer, and it does not work on any object.
Cut (CTRL-X), however, works.

Anyone else?

Thanks!
Best regards
Eugen


#2

No such problem here. Reboot?


#3

Rebootet Rhino WIP - same problem…


#4

The scene I noticed this was originally created in Rhino 5. So I just started with a fresh scene, with just a few lines - no, delete is broken (Cut works). History is turned off.
Rhino version: 6.0.17031.12411, 31.01.2017


#5

Does anything else not work, like the Esc key, for example? --Mitch


#6

Hello! Thanks!
ESC key works fine… Deleting components works, too.

In this second I found the cause:
there’s this (new?) mode, when objects are selected, their points are displayed automatically without having turned on ‘point display’.
It’s called “Turn on control points when selecting a curve”, under Options > Mouse.
In that case, the object cannot be deleted! Makes sense actually…
Duh…
Sorry for the noise!
Best
Eugen


#7

… which rises the question: if I actually like and want to use that mode - is there any modifier key combination / toggle to then select an object normally (without turning on the points)? Does not seem to be.


(Vanessa Steeg) #8

Does this macro do it for you?

-Options
M
S
U
Enter
Enter
Enter

It’s a toggle.


#9

Dunno, deleting objects with points on by using the delete key (or typing delete) works for me… --Mitch


#10

Odd. It does not here, definitely. Checked again.

  • under Options > Mouse > “Turn on Control Points…” ON
  • draw a line
  • select it (points are displayed)
  • press DEL - nothing!

#11

Hi!
Thanks, that macro works!

However, not sure if it makes sense to do it that way - putting that macro in a button or alias - since then I could as well just toggle the object’s points on, which goes against the whole idea of this new option.

Best regards
Eugen


#12

Well, there is definitely something wrong on your end - seems to work OK here and I agree it would be annoying if it didn’t… --Mitch


(Pascal Golay) #13

Hi All - there are two settings under Options > Mouse - one turns on points on selection, and one allows object selection with points on- the second one is the one that needs to be enabled to make Delete work.

https://mcneel.myjetbrains.com/youtrack/issue/RH-38024

-Pascal


#14

Thank you!
Right under my nose…