Definition was working until last week and now has stopped

Once the sizes are entered, our staff turn on the “nest and price” button and then click on “download summary PDF” button or any of the other download buttons dependant on their needs.

The following error message is returned Export “Download Summary PDF”

We are sorry, results for these parameter values can not be exported.

As mentioned, this was working without any issues until last Friday.

The definition is here

I believe the definition is not nesting and hence no data to export.
The definition still works correctly with grasshopper and Rhino 6

Your model is at the edge of your computation time limit and also times out with other parameter combinations not only when exporting PDFs. For example, changing “SUNBRELLA PLUS COLOUR” often gives an error.

PRO customers use the ShapeDiver shared system where performance fluctuations can occur and computation time might exceed for models that are near the limit as it happens in your case. Read more about computation time in here.

There are a few ways to solve this:

  • You can either optimise your model to decrease the processing time and stay within safe margins of your time allowance. Optimisation techniques are well covered in this blog post, video tutorial and the webinar.
  • Or you can increase your computation time limit. If you are interested in upgrading your account please contact sales via the contact form at
  • Our Grasshopper specialists can help you with your project. Ask the sales team for more details.

Hi Pavol.
We had been using the definition for around 4 months with no issues.
We had learned we needed to turn on the “nest and price” button ONLY after all measurements, options etc had been set and computed and this had worked consistently.

It would appear to me that the nesting is not working in Shapediver, even when there is is ]just one basic panel.
With nesting and price turned off, it works with any set of parameters I have tried and all previusly worked as long as nest and price was turned on after all parameters set and computed

I just tested nesting with OpenNest and it works fine. Makes sure you use the latest supported version, try re-uploading the file and let me know if you still have problems with timeout errors.

See this video tutorial for tips how to use nesting efficiently:

Thank you,
I’m presently watching the optimisation videos which are very helpful