Data Input and Output Null Data

Is it supposed to work this way? Point are saved correctly, but I have to internalise curves to be able to see them in data Input.

I think it’s a bug in Mac version of Grasshopper. I tested it again and it looks like points/breps work just fine.
The problem is with curves and surfaces. They work only when internalise.

Maybe @dan can check or help with it?

Thank you

Ok I don’t know if it supposed to work this way, but for anyone having the same problem you basically have to to do something with referenced information / geometry before you can pass it onto Data Output component.
This way all works
I have attached files if anyone needs them. (12.1 KB) (7.7 KB)

Hi @arten-

Sorry for the delayed reply. I’m sure there’s a bug here, but I could use your help making it clear to me. I think I’m probably overlooking something obvious here so I apologize in advance :wink:

I downloaded the gh files you posted, opened, referenced some Rhino geometry, then opened and everything worked. But these look to be the definitions with some workaround in them.

Can you do me a favor? Can you please post the original definitions that did NOT work? It would save time and guess-work.

Hi @dan,
Thank you for your reply. Yes will do. Basically it looks like only point work, but curves, brep’s and surfaces should be manipulated before hand…


Hey @arten-

Sorry this slipped off my radar for a few weeks. Can you please post the definition when you get the chance?


Hi @dan, sorry completely forgot about it.
Please see attached files

1.Rhino with referenced geometry
2.In and out grasshopper files

As you can see Grasshopper “In” file doesn’t read/display any data

Thank you (5.9 KB) (4.8 KB)

Ref.3dm (3.6 MB)

Hi again @arten-

Thanks for providing the files.

I just tried the following steps in Rhino 6 for Windows (6.20) to make sure that I understand the expected behavior:

  1. Launched Rhino 6 for Window 6.20 and opened your Ref.3dm.
  2. Ran Grasshopper and opened up the file you provided.
  3. In the Data Output node of, I set the Destination as Data.ghdata on the Desktop and made sure it ran once to save the data.
  4. In Grasshopper, I opened your that you provided.
  5. In the definition, in the Data Input node, I set the Source to the Data.ghdata file referenced above on the Desktop.

The Point component contains 5 Referenced Points.
The Curve component contains 2 Null Curves
The Surface component contains 1 Referenced Surface.
The Brep component contains 1 Referenced Brep.

Is that what you expect? None of the geometry appears in the viewport until I internalize the various geometry container nodes.

I get the same behavior in Rhino 6 for Mac 6.20.

I’m not saying the behavior is correct, I just want to make sure we’re on the same page. If this is not what you expect, then it looks like this is a general Grasshopper (ie: not just Mac) bug.

1 Like

Hi @dan yes it is exactly what I am getting. I have to internalised data before I can do any operations.
No live connections between the data fife and definition.
Would be good to have Bool toggle or refresh for Data component ?
Thank you

So, since this it is the same behavior in Rhino 6 for Windows SR 2.0, that means that this not specific to Grasshopper on Mac.

@DavidRutten can you please take a look? Above are the steps I took to test this.

@dan and @DavidRutten, Hi guys was it fixed or this is the way it should work?

I doubt this has been fixed…@DavidRutten would have to weigh in here.

Thank you