Dark images in cycles look very splotchy

This image is of a model that is self illuminated.

The image is dark, but that’s what I want.

What I don’t want is for the model to look like it has a skin disease.

Is there any setting in Rhino cycles that I can tweak to get a less splotchy image?

Only a couple of thoughts at the moment.

  • Not that this is a root-cause solution, but have you tried the Nvidia denoiser (or the Intel OpenImageDenoise)
  • I always immediately turn off the Gamma function in Cycles, because it seems more trouble than it’s worth. I don’t even know what it’s there for. Lighting adjustments may be required.


I turned it off and got this…

Turning up gamma makes image brighter, turning down makes dimmer. Either way it’s still blotchy.

Denoiser seems to accentuate the splotches.

I’m wondering if the splotchyness is simply the result of a 24 bit image, with only 8bit per color channel, so you are hitting the wall in terms of what can be displayed.

It does look like the results of using a 256 valued color pallet back in the Windows 3.1 days.

So I suspect that you are right.

I could try emulating the r7, behind, the camera light. I got some nice images from that. Or just use a brighter HDRI. I initially saw the splotchiness using a dimly lit scene and tried removing the other light sources to see if the problem was a low dynamic range: LDRI. :slight_smile:

Rhino Render will render with values outside 0.0-1.0 (0-255) range in the render window. If you want to preserve the full range then save as EXR.

You can also still play with the tonemapping post effect - set for instance to filmic with say low contrast.

By default tonemapping is set to clamping - which will… clamp values.

Here a simple scene with no gamma, some emitters at 20 and some emitters 10 or so

Now setting to filmic | low contrast I get:

Now, the above were with a skylight that had intensity set to 0.55. Below the same pair, but with no skylight

Note with the filmic/low contrast the color of the high-value emitter spots regain their original colors more or less.

Here saved out as EXR - you can check for instance in Blender that the spherical emitting objects have values beyond the 1.0 range

ship_emitter_save.exr (3.1 MB)

and here a file to play with. In case it helps figure things out. If I’m way off with my simple model - does it kind of represent what you are trying to accomplish? If not feel free to tweak to bring it closer to what you have and reshare so we all can have a look.

spaceship_emitters_lighting_only.3dm (424.2 KB)