Cutting meshes does not work


Why cannot I trim the object (topography - mesh layer) by the edges (edge layer)?

I have tried mesh trim, mesh split, boolean functions.

Sometimes it works but mostly not, God one knows why.

Any tips for it?

Kind regards


Hi Maciej,

What steps are you taking?

I was able to run MeshTrim individually on each off the cutting Objects and trim the mesh successfully (one at a time, not all at once)

1 Like

Hi Japhy,

  1. Mesh trim (select cutting objects)
  2. selected the north cutting mesh, pressed Enter (select object to trim)
  3. selected the main mesh - the topo model
    (cursor indicating something is happening, after it stopped, another prompt “Select objects to trim” and the main mesh is not trimmed

If I hit Enter just after " select object to trim" also nothing happens.

Only the southern edge was trimmed at first time and I think it is due to relative flatness of the area in this area.

A couple things might help here.

  1. Run Check on the topo mesh. It has self-intersecting faces and at least one very thin face.
  2. The mesh itself is starting to get down to tolerance sizes. Here are reports of edge lengths of .050 mm. This is in a model with .001 tolerances. Is it meant to be this small? If I scale the mesh up 10x it size it works ok. This means a tolerance of .0001 might also work if set in the file.

Here i trimmed and joined your Trim Meshes and trimmed all at once.


One at a time works great too.


Also note that I did this in Rhino 7 (similar to Rhino 6), Rhino 8 WIP has improved mesh boolean,trim commands.

“I did this in Rhino 7 (similar to Rhino 6), Rhino 8 WIP has improved mesh boolean,trim commands.”
OK. So this explains everything: improved mesh handling in version 7. Thanks.

Thanks. The object is meant to be so small. I’ve done what you suggested, no result however. It seems the version 6 does not handle meshes as well as version 7. I’ll finish my job by just deleting faces.

Finally I did the split on a fresh, big model (original scale), so your tip was right. Thanks.

please mark scott’s answer as solution / the topic as solved so others don t need to dig in.
thanks. kind regards. happy modelling. tom

Thanks for instructing :slight_smile: