Mesh Trim Error

Hi All,

I have a mesh topography which is pretty big and detailed. I want to trim it to a smaller frame and get rid off unnecessary parts but each time i try to trim or split it with the commands i know it doesnt work. I tried MeshTrim, SplitMesh, SplitMeshWithCurve, some GH Mesh Tools, MeshBooleanSplit even offsetted it and tried to MeshBooleanIntersection and other possible Boolean Operations. Also run MeshRepair and tried to find out what is wrong. It is such annoying cause i just want to cut it with a basic form.

Any suggestions what to do?
200621_MeshTrimProblem.3dm (14.2 MB)

Are you running Rhino on a Windows machine or Mac? If Windows I might be able to help with a mesh trimming script I wrote that often works when Rhino’s tools fail.

Have you tried Rhino 7 WIP mesh tools? They have some improvements.

I use it on Win. No Rhino 7 WIP i still didnt check it s new features. Yeah it would be great if you can help with your script!


OK. I have a meeting in a few minutes after which I will try my script on your mesh example. If it works, I will post it along with details for running it.

The quality of this mesh really doesn’t help… Type “Check” and read

If you look at every single mesh face, there are other problems but at least you can split the faces.

The Grasshopper file is attached. It takes a while to execute. You might want to disable the Intersection in between the elliptical surface and the mesh surfaces. (16.7 KB)

@martinsiegrist wow this is awesome. its a huge help thanks a lot. i cant check it right now but i am gonna check it at home.

Hello - looks like V7/WIP can split this mesh if it is first cleaned up a bit - ExtractNonmanifoldMeshEdges, SplitDisjintMesh, then split what remains…


1 Like