Custom UI settings R6 not working properly

Put a lot of time to configure R6 UI to my workflow. Sadly it does not work! When I press button/commands on newly create top row, the commands don not or partly work?

I created this row because it is impossible to create personalised ribbon?

Why is this not working?

Peter

Hi Peter, Can you select one of the icons in your VP palette in the Command editor so I can see the command macro it’s running? This is working here but I don’t have your custom palette. You can also email tech@McNeel.com to my attention.

Good day Brain,

Thanks for reaching out,

Not sure why I encountered issues earlier on bud for now it seem to work fine?
Though I do encounter the following with the commands “Grid display off” & “Grid display on”
Activating those commands will also open the settings pallet?

If you need further info, do not hesitate.

Have a nice day,

Peter

Screenshot 2020-10-08 at 09.59.17.pngScreenshot 2020-10-08 at 09.59.56.png

Hi Peter,

Thanks for the update, I’m glad your icons are working again.

Regarding the new issue you mentioned with the Grid, I haven’t been able to reproduce this here in Rhino 6 for Mac using either the Grid settings in File > Settings or by using the Grid command. Do you use a Display mode specific setting for the Grid in any display mode? You can check in Preferences (Cmd+,) > Display Modes. This would override the document setting for the Grid.

If that is not the cause, can you provide reproduceable steps to cause what you’re seeing? Thanks.

Good day Brian,

Indeed I do use Display mode specific settings for all my Display modes.
So if I understand correctly, when I want to toggle my grid “on” or “off” due to my custom Display settings it also toggles the “settings panel”?

Enjoy the weekend,

Peter

The Grid control in File > Settings will only impact a display mode if that display mode is set to use the Document settings for the Grid. If however, the display mode uses a custom mode specific grid setting, the Grid control in File > Settings will not have an effect. I have experimented with display mode grid settings and document grid settings but so far don’t see any conflict here. Can you provide the steps to see what’s happening on your end? It would be good to have your display mode used in the viewport as well… use the gear icon at the bottom of Preferences > Display Modes when the mode name is selected to export it.

Hi Brian,

Not sure what I’m doing on my side I’m not a power user.

Bud when I click on “Grid On” or "Grid Off” the settings panel pops up!
[Left Click] on [Grid On] shows Grid + settings panel pop up
[Left Click] on [Grid of] shows no Grid + settings panel pop up

Also tried different combinations with the viewport, single and quad, same result.

Also copied the viewport settings bud when selected these gave the same results.

I have attached my viewport setting and also took a screenshots of Themes and Command Editor

Shaded.ini (6.54 KB)

Rendered.ini (6.31 KB)

Wireframe.ini (6.31 KB)

Thanks for the additional details, I think I understand what you’re trying to change now. If you edit the macros for this icon in your custom pop up you can toggle the grid on/off without showing the document properties dialog. Here’s an example of what the macros should look like.

To change the macro used, click on the two sections at the top right of the command editor. You can also use the search field at the bottom left of the editor to find other icons to drag and drop into your custom pop up.

Ahaaa…Yes there’s no bug it has to do with the script [ NoEcho-DocumentProperties _Grid _ShowGrid=_No _EnterEnd], firing this script will give you the setting-property panel. This script will not [ _NoEcho _Grid _ShowGrid=_No _EnterEnd]! Thanks.

Though I made a mistake by editing the script of [Grid display off] in the right lower conner and lost the [Grid display off] Icon?
How do I retrieve this this icon?
I don’t see it in the lower left window pan entering “Grid”.
I only get the [Grid display on] icon see screen shot.

Though the [Grid display on] in the modified palet works fine.
No properties panel popping up when firing this command.

If you type “Grid Display” in the bottom left search field do you see it? I can’t reproduce making it disappear there by editing the macro but if you do want to return a macro to the default settings, select the icon in the lower left section and click the - symbol.

If I type “Grid Display” I do not get the original icon as you can see in the screenshot?

What happens if you click the - symbol now when Grid Display Off is selected? Does it revert to the default image and macro? If not, do you recall how you edited the macro that caused the icon bitmap to go missing?

If I switch between the icon “Grid display on” to “Grid display off” it does not revert to the default image.
Lower left and right give the question mark image.

Yes I recall the steps:Opened “Command Editor”—Under “MODIFIED PALETTES”—Left Click “VP_Tools”—Left Click “Grid display off” icon—Left Click upper right window pan “Grid display off” icon—Altered the script “NoEcho-DocumentProperties _Grid _ShowGrid=_No _EnterEnd" in lower right window pan into "_NoEcho _Grid _ShowGrid=_No _EnterEnd”

But I missed a space or typo?
This is were my icon vanished.

I am not able to reproduce the loss of the icon bitmap, sorry. Did you click the “-” symbol in the lower left corner of the editor when this icon was selected? You could also make a new copy of your Default file to start over or give the Grid Display On icon a right click macro.

I can’t recall clicking the “-“ minus/remove button but maybe I did?

No worries it’s not imperative, I do have the keyboard shortcut “F7” and "Right Click”

Thanks Brian,

Have a nice day,

Peter

If you do click the - when the icon is selected, it should reset to the defaults. This is what I was hoping would fix the missing icon for you.