Curve Components Missing

I’m having some trouble with some components not showing up. I’ve tried repairing and reinstalling Rhino but that didn’t work. Anyone have any clue how I would fix this?

Are there any messages in the Rhino command history when Grasshopper loads?

No there isn’t anything

I’m reasonably sure the components you do see are actually part of the VectorComponents.gha, which would mean the CurveComponents.gha isn’t loading at all.

I can look into this further when at the office tomorrow, but if you can find all folders on your machine which contain *.gha files and screenshot them, that’ll help as well.

I believe this is the only folder

I’ve also noticed when I reinstalled it kept most of my settings. Is there way to completely reset everything to the original state?

Delete that CurveComponents.no6, dunno where you picked that up from, but that would prevent the CurveComponents from loading in R6 gh.


Thanks, that fixed it!

FYI, you also have Python blocked in R6 as well.

Is there a way to download the curve components separately in order to reinstall it? Can someone show me the link please?

No, they are installed along with grasshopper and Rhino. If they’ve disappeared from your computer, you’ll need to reinstall our update your Rhino. Getting just the CurveComponents.gha from someone else may work, but you’d be better off getting the for which was compiled against the exact versions of Rhino and Grasshopper you have installed.